Can't run chibistudio_preview20

Discussions and support about ChibiStudio, the free development environment for ARM.
johncblacker
Posts: 11
Joined: Sat Mar 30, 2019 8:12 pm

Can't run chibistudio_preview20

Postby johncblacker » Sat Mar 30, 2019 8:25 pm

I recently downloaded and unzipped the chibiStudio_Preview20 package, however it will not run. I did install java jre 32-bit, but I got a message saying it couldn't find the javaw in the ...eclipse/jre/bin directory. So I copied the 32-bit jre /bin and /lib directories into the chibiStudio/eclipse/jre directory but it still says it can't load the JNI jvm.dll. I put both the ./eclipse/jre/bin and ./eclipse/jre/bin/server directories into my PATH variable at the top, but it stil won't run. I do have java 64-bit also installed on this machine and notice in my environment variables the JAVA_HOME variable is pointing to the 64-bit java home. Do I need to modify that variable also? This seems like a nuisance to have to modify variables everytime I want to run chibiStudio and then have to reset them back after I'm done so that other eclipse's that I have (2 of them, 64-bit) will run. How can I get around this issue?

User avatar
Giovanni
Site Admin
Posts: 11831
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 522 times
Been thanked: 433 times
Contact:

Re: Can't run chibistudio_preview20

Postby Giovanni » Sat Mar 30, 2019 9:14 pm

Hi,

This never happened to me, I have both Java 32 and 64. It seems you have problems with your java installation. Try to uninstall both then install first 32 then 64 again.

Giovanni

johncblacker
Posts: 11
Joined: Sat Mar 30, 2019 8:12 pm

Re: Can't run chibistudio_preview20

Postby johncblacker » Sun Mar 31, 2019 3:10 pm

I removed all versions of Java on my system, then reinstalled java 1.8 32-bit. Still got the exit code=13 error. Attached is a picture of the output
from eclipse/java. File is attached...sorry I couldn't get a better listing but I couldn't select the text in the window so I had to resort to ctrll-print screen in Win 10, crop it in paint and attach. This is just nuts. What I did after reinstall of java was go to the chibistudio eclipse directory in a cmd window, updated the PATH variable, adding the "Program Files\Java\jdk1.8.0_201\bin" directory as the first one in PATH, then I simply executed eclipse.exe.
Attachments
eclipse-output.png

User avatar
Giovanni
Site Admin
Posts: 11831
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 522 times
Been thanked: 433 times
Contact:

Re: Can't run chibistudio_preview20

Postby Giovanni » Sun Mar 31, 2019 4:27 pm

Hi,

It is possible that your ChibiStudio installation is corrupted, could you reinstall it while your antivirus is disabled? there have been cases where the installation gets corrupted because background scanning.

You may then scan it after installation if you so wish.

Giovanni

johncblacker
Posts: 11
Joined: Sat Mar 30, 2019 8:12 pm

Re: Can't run chibistudio_preview20

Postby johncblacker » Sun Mar 31, 2019 6:03 pm

OK, I will try that step again.

johncblacker
Posts: 11
Joined: Sat Mar 30, 2019 8:12 pm

Re: Can't run chibistudio_preview20

Postby johncblacker » Sun Mar 31, 2019 8:02 pm

No matter what I do, I still get exit code 13. I've tried changing the eclipse.ini file to point to: java, javaw.exe and jvm.dll but nothing works. I have my virus scanner off when I loaded the chibistudio.7z. I removed the c:\ProgramData\Oracle\Java\javapath from my system environment variable path and pointed directly at the version in c:\Program Files. I included a -vm c:\Progra~1\Java\jre1.8.0_60\bin\javaw.exe in case there was an issue with spaces in the path of the -vm parameter. Nothing seems to work. At this point, I get the eclipse splash screen (which I hadn't gotten before) and then the window with the exit code 13 stuff. So, I've spent two days on this and am ready to call it quits. I've got to reinstall the java 64-bit so my other stuff will run. Thanks for trying to help. I think the best thing would be to move things over to 64-bit eclipse.

User avatar
Giovanni
Site Admin
Posts: 11831
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 522 times
Been thanked: 433 times
Contact:

Re: Can't run chibistudio_preview20

Postby Giovanni » Sun Mar 31, 2019 8:47 pm

You may just replace eclipse into ChibiStudio but make sure to use Luna or Mars. If it works you may install the plugins specific of ChibiStudio from this update site: http://www.chibios.org/eclipse/chibistudio

ChibiStudio is Eclipse Luna for Java, XML and C/C++ support is installed on top of that (there are also terminal, freemarker support and other minor things but not mandatory).

The only problem is why it does not work, we made literally hundreds installations during our trainings in universities. Could you try on another PC? just to know.

Giovanni

johncblacker
Posts: 11
Joined: Sat Mar 30, 2019 8:12 pm

Re: Can't run chibistudio_preview20

Postby johncblacker » Sun Mar 31, 2019 8:52 pm

Success finally! I'm embarassed to report that the problem was mine all along. I had a brain fa-t and mixed up where windows 10 was putting 32-bit apps vs. 64-bit apps. So, I was always pointing to a version in Program Files which are all 64-bit apps. I finally redid my 32-bit version install and pointed to the Program Files (x86) folder and all is well! I really apologize for taking your time. In retrospect, we both should have caught the error long ago! But, water under the dam, as they say. IT'S WORKING! Close this as SOLVED.

johncblacker
Posts: 11
Joined: Sat Mar 30, 2019 8:12 pm

Re: Can't run chibistudio_preview20

Postby johncblacker » Sun Mar 31, 2019 9:00 pm

Now that I've git it working, I was expecting to see some Chibios examples for various platforms; but I don't see any such thing, so obviously, I've got to do some research to find the exmples for the various boards. I started a c++ application, but I didn't get to selecting a board.

User avatar
Giovanni
Site Admin
Posts: 11831
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 522 times
Been thanked: 433 times
Contact:

Re: Can't run chibistudio_preview20

Postby Giovanni » Mon Apr 01, 2019 7:50 am

Hi,

In ChibiStudio there are several workspaces, initially you are in an user workspace which is empty. From Eclipse file menu switch workspace to 19.1 or trunk, all demos are in there.

You can also "import" demos in the user workspace after first trials and use those as starting points for your work.

I recommend to try http://www.playembedded.org and follow the tutorials there.

Giovanni


Return to “ChibiStudio”

Who is online

Users browsing this forum: No registered users and 0 guests