STM32VLD support

This forum is about you. Feel free to discuss anything is related to embedded and electronics, your awesome projects, your ideas, your announcements, not necessarily related to ChibiOS but to embedded in general.
misterno
Posts: 5
Joined: Thu Jan 10, 2019 2:15 pm

STM32VLD support

Postby misterno » Wed Jul 03, 2019 10:26 am

Dear forum,

Hi. I need info's how to program STM32VLD discovery kit inside from the chibistudio. This kit works in WDA mode but it has ST-LINK v2 as well. Any tutorial about it? Have in mind that i only managed to program this kit only with the ST-LINK utility came from ST.com. TIA.

User avatar
Giovanni
Site Admin
Posts: 11935
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 535 times
Been thanked: 447 times
Contact:

Re: STM32VLD support

Postby Giovanni » Wed Jul 03, 2019 10:46 am

Hi,

There is a demo for that board in ChibiStudio under /demos/STM32/RT-STM32F100-DISCOVERY.

Guides and tutorials regarding ChibiStudio are on http://www.playembedded.org you may want to watch the introduction video tutorial.

Giovanni

misterno
Posts: 5
Joined: Thu Jan 10, 2019 2:15 pm

Re: STM32VLD support

Postby misterno » Wed Jul 03, 2019 11:32 am

Thank you for reply,

i 've already did registration but no approve email received yet.
By the way if you can tell me whats wrong, here it is the console message i get when i try to build the project you mention.
I've tryed to link with st-link option and retrieve the board script file stm32vldiscovery.cfg

Open On-Chip Debugger 0.10.0+dev-00746-g8f518d359 (2019-03-14-17:18)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
Warn : Interface already configured, ignoring
Error: already specified hl_layout stlink
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
adapter speed: 1000 kHz
adapter_nsrst_delay: 100
none separate
srst_only separate srst_nogate srst_open_drain connect_deassert_srst
Info : Listening on port 6666 for tcl connections
Info : Listening on port 4444 for telnet connections
Info : clock speed 1000 kHz
Error: libusb_open() failed with LIBUSB_ERROR_NOT_SUPPORTED
Error: open failed


Any ideas what to do next?

User avatar
Giovanni
Site Admin
Posts: 11935
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 535 times
Been thanked: 447 times
Contact:

Re: STM32VLD support

Postby Giovanni » Wed Jul 03, 2019 12:07 pm

Sorry, registration for what?

Giovanni

misterno
Posts: 5
Joined: Thu Jan 10, 2019 2:15 pm

Re: STM32VLD support

Postby misterno » Wed Jul 03, 2019 12:17 pm

Registration to this forum
http://forum.playembedded.org/


Return to “User Projects”

Who is online

Users browsing this forum: No registered users and 1 guest