EFL Flash Sectors on STM32G0 Topic is solved

Report here problems in any of ChibiOS components. This forum is NOT for support.
aport
Posts: 35
Joined: Sat May 10, 2014 7:35 pm
Has thanked: 2 times
Been thanked: 4 times

EFL Flash Sectors on STM32G0  Topic is solved

Postby aport » Tue Apr 21, 2020 9:08 pm

Hi there,

I've been trying to use the EFL driver on an stm32g071 and I was running into some problems. I think the number of pages is incorrectly assigned which leads to sectors_size being 512 bytes instead of 2k.

As the datasheet specifies 32 or 64 pages of 2k, I changed the lines:

#define STM32_FLASH_SECTORS_TOTAL_64K 128
#define STM32_FLASH_SECTORS_TOTAL_128K 256

to

#define STM32_FLASH_SECTORS_TOTAL_64K 32
#define STM32_FLASH_SECTORS_TOTAL_128K 64

And everything started working as I expected.

User avatar
Giovanni
Site Admin
Posts: 12962
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 735 times
Been thanked: 610 times
Contact:

Re: EFL Flash Sectors on STM32G0

Postby Giovanni » Tue Apr 21, 2020 9:15 pm

Hi,

Moving this topic to bug reports.

Giovanni

User avatar
FXCoder
Posts: 272
Joined: Sun Jun 12, 2016 4:10 am
Location: Sydney, Australia
Has thanked: 106 times
Been thanked: 87 times

Re: EFL Flash Sectors on STM32G0

Postby FXCoder » Wed Apr 22, 2020 7:55 am

Fixed in trunk as bug #1085
Back ported to 20.3.x

aport
Posts: 35
Joined: Sat May 10, 2014 7:35 pm
Has thanked: 2 times
Been thanked: 4 times

Re: EFL Flash Sectors on STM32G0

Postby aport » Thu Apr 23, 2020 5:39 am

Awesome, thank you so much!


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 3 guests