Possible bug in STM32L4xx series registry Topic is solved

Report here problems in any of ChibiOS components. This forum is NOT for support.
Posts: 23
Joined: Thu Aug 31, 2017 6:32 pm
Has thanked: 4 times
Been thanked: 5 times

Possible bug in STM32L4xx series registry  Topic is solved

Postby heliochronix » Sun Jul 14, 2019 3:23 am


This is with regards to trunk@12906, on the STM32L4xx series. It's only a possible bug due to an observed discrepancy between the Reference Manual and ChibiOS configuration code. I'm just bringing it up to hopefully determine if it really is an issue.

When I was adding L452 support to ChibiOS, I noticed in STM32L4xx/stm32_registry.h that all the L4xx series (including L4xx+) have the following definitions for EXTI Line0 handlers:

Code: Select all

#define STM32_EXTI_LINE0_HANDLER            Vector58
#define STM32_EXTI_LINE1_HANDLER            Vector5C

However, while reading through the STM32L4xx Reference Manual, in particular Section 12.3 where a table of these values are enumerated, I noticed that the manual specifies Line0 and Line1 should both be set to 0x0000005C (AKA Vector5C).

I haven't noticed anything yet to indicate this is causing a problem, but I noticed the discrepancy and I thought I would bring it up just in case it has the potential to cause problems. I'm not sure if the Reference Manual has a typo (should they be identical?) or if ChibiOS has a bug that simply hasn't manifested yet due to no one having used that subsystem yet. Or perhaps this isn't even an issue and nothing bad would happen if someone did.

Anyway, I was thinking maybe there is some way we can conclusively determine if this is an issue. I personally haven't worked with that subsystem directly, so I'm not sure I understand the ins and outs of it well enough to test it thoroughly, but I could try if needed. Anyone else have a thought or some insight?

User avatar
Site Admin
Posts: 13121
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 769 times
Been thanked: 653 times

Re: Possible bug in STM32L4xx series registry

Postby Giovanni » Sun Jul 14, 2019 7:12 am

It is an error in the manual, if you look at the "vector position" column it becomes clear.


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 3 guests