test suite Topic is solved

Report here problems in any of ChibiOS components. This forum is NOT for support.
Eddie
Posts: 44
Joined: Sat Mar 16, 2013 5:57 pm
Location: Czech Republic
Has thanked: 2 times
Been thanked: 6 times

test suite  Topic is solved

Postby Eddie » Wed Nov 01, 2017 6:15 pm

Test suite freeze from shell comandline.
Latest Chibios trunk.

User avatar
tfAteba
Posts: 526
Joined: Fri Oct 16, 2015 11:03 pm
Location: Chartres, France
Has thanked: 80 times
Been thanked: 46 times

Re: test suite

Postby tfAteba » Wed Nov 01, 2017 7:37 pm

Hi Eddie,

Thanks for reporting, can you add the output of the test suite and also tell us the board using while making the test.

Those information will help Giovanni to investigate :)
regards,

Theo.

User avatar
Giovanni
Site Admin
Posts: 12949
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 733 times
Been thanked: 609 times
Contact:

Re: test suite

Postby Giovanni » Wed Nov 01, 2017 9:41 pm

I think it does not even start correct? this should be caused by recent changes to the test engine.

Giovanni

Eddie
Posts: 44
Joined: Sat Mar 16, 2013 5:57 pm
Location: Czech Republic
Has thanked: 2 times
Been thanked: 6 times

Re: test suite

Postby Eddie » Thu Nov 02, 2017 8:51 am

Hi,
yes, test suite not start, no output to terminal.

Eddie

User avatar
Giovanni
Site Admin
Posts: 12949
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 733 times
Been thanked: 609 times
Contact:

Re: test suite

Postby Giovanni » Sun Nov 05, 2017 2:09 pm

Hi,

It should be fine now, note that the syntax of the "test" command changed a bit.

Giovanni

Eddie
Posts: 44
Joined: Sat Mar 16, 2013 5:57 pm
Location: Czech Republic
Has thanked: 2 times
Been thanked: 6 times

Re: test suite

Postby Eddie » Fri Nov 24, 2017 5:14 pm

Hi,
a few days ago the test worked well, but now on current trunk freeze oslib test in step 4.1

User avatar
Giovanni
Site Admin
Posts: 12949
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 733 times
Been thanked: 609 times
Contact:

Re: test suite

Postby Giovanni » Fri Nov 24, 2017 10:17 pm

Which platform/board?

Giovanni

Eddie
Posts: 44
Joined: Sat Mar 16, 2013 5:57 pm
Location: Czech Republic
Has thanked: 2 times
Been thanked: 6 times

Re: test suite

Postby Eddie » Sat Nov 25, 2017 10:46 am

Last trunk, board STM32F103 Nucleo.

User avatar
Giovanni
Site Admin
Posts: 12949
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 733 times
Been thanked: 609 times
Contact:

Re: test suite

Postby Giovanni » Sat Nov 25, 2017 1:16 pm

Hi,

I am testing the STM32F103-NUCLEO64 demo but the test suite does not hang. Do you have enough stack for the test suite in your application? Which compiler are you using? does it crash or it is looping somewhere?

Giovanni

Eddie
Posts: 44
Joined: Sat Mar 16, 2013 5:57 pm
Location: Czech Republic
Has thanked: 2 times
Been thanked: 6 times

Re: test suite

Postby Eddie » Sat Nov 25, 2017 4:47 pm

I do not have hardware now, so I can provide more information on Monday. If I remember, the test stopped at assertion.
Test project in attachment. Compiler GCC 6.3, Chibistudio 19.

Eddie
Attachments
RT-STM32F103RB-NUCLEO64.ZIP
(15.08 KiB) Downloaded 46 times


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 7 guests