NIL documentation bug Topic is solved

Report here problems in any of ChibiOS components. This forum is NOT for support.
vctrvlad
Posts: 21
Joined: Mon Aug 28, 2017 2:27 pm
Location: Timisoara, Romania
Has thanked: 1 time
Been thanked: 3 times

NIL documentation bug  Topic is solved

Postby vctrvlad » Tue Sep 19, 2017 7:07 pm

I have found many places in the documentation in the topic description, where information is redundant
eg.
• #define CH_CFG_ST_TIMEDELTA 0
Time delta constant for the tick-less mode.
• #define CH_CFG_ST_TIMEDELTA 0
Time delta constant for the tick-less mode.

And a lot other redundat info in the documentation?
http://chibios.org/dokuwiki/lib/exe/fet ... nil_rm.pdf
page 12 of the documentation, page 22 of the PDF document.

And also info like:
• #define CH_CFG_USE_MAILBOXES TRUE
Mailboxes APIs.
• #define CH_CFG_USE_MAILBOXES FALSE
Mailboxes APIs
on the same page, one after another...this is confusing, what is the purpose of this information anyway?

Regards,
Victor

P.S.
"5.4.2.22 #define CH_CFG_ST_TIMEDELTA 0
Time delta constant for the tick-less mode.
Note
If this value is zero then the system uses the classic periodic tick. This value represents the minimum number
of ticks that is safe to specify in a timeout directive. The value one is not valid, timeouts are rounded up to this
value.
ChibiOS/NIL
22 Module Documentation
5.4.2.23 #define CH_CFG_ST_TIMEDELTA 0
Time delta constant for the tick-less mode.
Note
If this value is zero then the system uses the classic periodic tick. This value represents the minimum number
of ticks that is safe to specify in a timeout directive. The value one is not valid, timeouts are rounded up to this
value.
"
???????????

Please, don't take any offence, I am just trying to figure out how this OS is working, and what is the correct way to use it.

User avatar
Giovanni
Site Admin
Posts: 13085
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 759 times
Been thanked: 637 times
Contact:

Re: NIL documentation bug

Postby Giovanni » Sat Sep 23, 2017 4:10 pm

Fixed as bug #887.

Giovanni


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests