Missing defintion in STM32F4 hal_lld.c Topic is solved

Report here problems in any of ChibiOS components. This forum is NOT for support.
neums
Posts: 136
Joined: Fri May 08, 2015 1:09 pm
Location: Dresden, Germany
Has thanked: 10 times
Been thanked: 5 times

Missing defintion in STM32F4 hal_lld.c  Topic is solved

Postby neums » Fri Apr 21, 2017 7:33 am

Hi,
in the hal_lld.c of th STM32F4 the definition STM32_PLLSAIR_POST is used in the function void stm32_clock_init(void) but it is not defined at all. Is this a bug?

Thanks

neums
Posts: 136
Joined: Fri May 08, 2015 1:09 pm
Location: Dresden, Germany
Has thanked: 10 times
Been thanked: 5 times

Re: Missing defintion in STM32F4 hal_lld.c

Postby neums » Fri Apr 21, 2017 7:34 am

It is also not defined in the reference manual.

User avatar
RoccoMarco
Posts: 557
Joined: Wed Apr 24, 2013 4:11 pm
Location: Salerno (Italy)
Has thanked: 66 times
Been thanked: 50 times
Contact:

Re: Missing defintion in STM32F4 hal_lld.c

Postby RoccoMarco » Fri Apr 21, 2017 7:58 am

Hi,
maybe it is defined in CM-SIS headers. Note that certain parts depends on specific MCUs
Ciao,
RM

neums
Posts: 136
Joined: Fri May 08, 2015 1:09 pm
Location: Dresden, Germany
Has thanked: 10 times
Been thanked: 5 times

Re: Missing defintion in STM32F4 hal_lld.c

Postby neums » Fri Apr 21, 2017 8:46 am

STM32_PLLSAIR_POST is not defined in any cmsis header file.

User avatar
RoccoMarco
Posts: 557
Joined: Wed Apr 24, 2013 4:11 pm
Location: Salerno (Italy)
Has thanked: 66 times
Been thanked: 50 times
Contact:

Re: Missing defintion in STM32F4 hal_lld.c

Postby RoccoMarco » Sat Apr 22, 2017 2:20 pm

clock init for STM32F4 has been already edited on trunk and this line has been completely removed. Since the whole edit impacts on certain features it has not been backported to 16.1.x and will be released with 17.x.

The question is: this line causes some compile error or unwanted behaviour on 16.1.x? If the answer is yes how can I reproduce that condition?
Ciao,
RM

User avatar
Giovanni
Site Admin
Posts: 10331
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 230 times
Been thanked: 205 times
Contact:

Re: Missing defintion in STM32F4 hal_lld.c

Postby Giovanni » Tue Apr 25, 2017 9:11 am

Fixed as bug #834.

Giovanni


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 0 guests