Error in Chibisutdio

Discussions and support about ChibiOS/RT, the free embedded RTOS.
smjh1371
Posts: 25
Joined: Sat Feb 06, 2016 2:05 pm

Re: Error in Chibisutdio

Postby smjh1371 » Mon Mar 28, 2016 5:54 pm

Could you please take a look at the attachment file. This is the console output of the Chibistudio.
Attachments
111.png

User avatar
Giovanni
Site Admin
Posts: 12950
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 733 times
Been thanked: 609 times
Contact:

Re: Error in Chibisutdio

Postby Giovanni » Mon Mar 28, 2016 11:05 pm

You are using 2.6-style paths on version 16.1.

Make sure to use a makefile taken from the version you are using.

Giovanni

smjh1371
Posts: 25
Joined: Sat Feb 06, 2016 2:05 pm

Re: Error in Chibisutdio

Postby smjh1371 » Wed Mar 30, 2016 6:45 pm

I'm confused. The version of Chibistudio is one thing and the version of chibios is something else. Am I right?
which version of chibistudio shoud I use for chibios 2.6.1??

User avatar
Giovanni
Site Admin
Posts: 12950
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 733 times
Been thanked: 609 times
Contact:

Re: Error in Chibisutdio

Postby Giovanni » Wed Mar 30, 2016 7:11 pm

ChibiStudio contains all versions: 2.6, 3.0 and 16.1, the default is the most recent one, 16.1.

If you want to compile a project created for 2.6.x then you need to switch to that version first. Under the "file" menu there is "switch workspace", select "workspace 26" and import your project there.

Giovanni

smjh1371
Posts: 25
Joined: Sat Feb 06, 2016 2:05 pm

Re: Error in Chibisutdio

Postby smjh1371 » Wed Mar 30, 2016 7:45 pm

I did that too.Nothing changed !I shifted to workspace26 and also changed the address to ../../chibios26 .
Attachments
qq.png

smjh1371
Posts: 25
Joined: Sat Feb 06, 2016 2:05 pm

Re: Error in Chibisutdio

Postby smjh1371 » Fri Apr 01, 2016 5:24 pm

do you have any idea ??

Marco
Posts: 128
Joined: Tue Apr 16, 2013 8:22 pm
Has thanked: 4 times
Been thanked: 11 times

Re: Error in Chibisutdio

Postby Marco » Fri Apr 01, 2016 6:55 pm

Hi,

Where is your ball balancing project located? I guess CHIBIOS is still pointing to the wrong location.

Marco

smjh1371
Posts: 25
Joined: Sat Feb 06, 2016 2:05 pm

Re: Error in Chibisutdio

Postby smjh1371 » Sat Apr 02, 2016 5:56 pm

I'm totally confused. It's in C:\ChibiStudio\workspace26 . by the way I sometimes get this error .this is the last time compilation.
Attachments
5553.png

Dwar
Posts: 12
Joined: Fri Jan 08, 2016 2:04 pm
Location: USA
Has thanked: 4 times
Been thanked: 3 times

Re: Error in Chibisutdio

Postby Dwar » Sun Apr 03, 2016 7:28 am

Have you tried opening and building a demo in 2.6?

You don't need to modify the Makefile to build the demos. Start simply and try to understand the build process before you dig in deeper.

smjh1371
Posts: 25
Joined: Sat Feb 06, 2016 2:05 pm

Re: Error in Chibisutdio

Postby smjh1371 » Fri Apr 08, 2016 10:44 am

do I need to install arm-gnu toolchain and yagarto tools for the version 17 or they're already there ?
there are no special settings for win 8.1 ? I'm getting the errors I asked again and again and nothing works!!!!!


Return to “ChibiOS/RT”

Who is online

Users browsing this forum: No registered users and 1 guest