Error in Chibisutdio

Discussions and support about ChibiOS/RT, the free embedded RTOS.
User avatar
Giovanni
Site Admin
Posts: 9815
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 159 times
Been thanked: 144 times
Contact:

Re: Error in Chibisutdio

Postby Giovanni » Fri Apr 08, 2016 11:08 am

smjh1371 wrote:do I need to install arm-gnu toolchain and yagarto tools for the version 17 or they're already there ?
there are no special settings for win 8.1 ? I'm getting the errors I asked again and again and nothing works!!!!!


You don't need to install anything, it is supposed to work out-of-box.

I don't know why it does not work for you but it woks for the rest of the planet, I already suggested all the known causes of problems and I am out of ideas now.

My final recommendation: try installing it on another PC.

Giovanni

smjh1371
Posts: 25
Joined: Sat Feb 06, 2016 2:05 pm

Re: Error in Chibisutdio

Postby smjh1371 » Fri Apr 08, 2016 11:53 am

I tried it on another PC ! the same problem

smjh1371
Posts: 25
Joined: Sat Feb 06, 2016 2:05 pm

Re: Error in Chibisutdio

Postby smjh1371 » Fri Apr 08, 2016 5:38 pm

I don't get it . Sometimes I get this error

make: *** No rule to make target `../../chibios/os/ports/GCC/ARMCMx/rules.mk'. Stop. BallBalancing_ChibiOSRT C/C++ Problem
and sometimes I get this one

make: *** No rule to make target `../ChibiOS-RT/os/ports/GCC/ARMCMx/crt0.c', needed by `build/obj/crt0.o'. Stop. BallBalancing_ChibiOSRT C/C++ Problem

and also

make: *** No rule to make target `BallBalancing_ChibiOSRT_scd.mk'. Stop. BallBalancing_ChibiOSRT [Discovery Options] page in project properties C/C++ Problem


?????????

access777
Posts: 8
Joined: Fri Apr 21, 2017 4:10 pm
Has thanked: 2 times
Been thanked: 1 time

Re: Error in Chibisutdio

Postby access777 » Wed May 03, 2017 11:29 pm

Hello!
I have the same trouble. I'm nub. I have the project made for Chibios267 ver and 10 ver of the Chibistudio.
I have try to compile my proj in the latest ver of the Chibistudio
- The project correctly compiles in the old ver of the Chibistudio
- I correctly unpack the new ver, 17 of the Chibistudio
- I have made an import of the proj into 26 workspace
- I made the 26 workspace as an actual in the file menu
- I have corrected mk file
But I have the trouble... May be there is in 267 ver project is an another file should be corrected with the path, not only Makefile?
Screenshot_3.jpg

Screenshot_2.jpg

Screenshot_1.jpg

access777
Posts: 8
Joined: Fri Apr 21, 2017 4:10 pm
Has thanked: 2 times
Been thanked: 1 time

Re: Error in Chibisutdio

Postby access777 » Thu May 04, 2017 11:31 am

My problem was solwed by folowing the adwise
"Project properties then do "Restore Defaults" on everything under C/C++."

access777
Posts: 8
Joined: Fri Apr 21, 2017 4:10 pm
Has thanked: 2 times
Been thanked: 1 time

Re: Error in Chibisutdio

Postby access777 » Mon May 15, 2017 10:10 pm

Hello!
The problem was NOT solved in previous way!!! It's my fault, but I have correct the mistake.
The problem has fixes in crt0.o.d file that was in my project from examples of an old version Chibios

All files in the .dep folder of the source project have the old path to the files '...Chibistudio\Chibios...' and should be edited for correct compiling.
I'm a nub. I've just found the problem. So may be somebody can offer more easy way?
So, that's all. If it's possible, I have a wish - to have a reliable tool to make a new pojects without copy-pasting of examples...
Screenshot_1.png

Screenshot_2.png

User avatar
Giovanni
Site Admin
Posts: 9815
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 159 times
Been thanked: 144 times
Contact:

Re: Error in Chibisutdio

Postby Giovanni » Tue May 16, 2017 8:19 am

Hi,

If you have a 2.6 project you need to switch to the 2.6 workspace in ChibiStudio and import your project there, the default workspace is for 16.1 projects.

Files in .dep are generated during compilation, you are not supposed to edit those. Do a "clean" and .dep will be erased.

Giovanni

access777
Posts: 8
Joined: Fri Apr 21, 2017 4:10 pm
Has thanked: 2 times
Been thanked: 1 time

Re: Error in Chibisutdio

Postby access777 » Tue May 16, 2017 3:16 pm

Thanks a lot!
Yes, after build folder cleaning the project compiles Ok
Screenshot_3.png


Return to “ChibiOS/RT”

Who is online

Users browsing this forum: No registered users and 1 guest