chibios with arduino uno Topic is solved

ChibiOS public support forum for topics related to the Atmel AVR family of micro-controllers.

Moderators: utzig, tfAteba

hackem
Posts: 3
Joined: Mon Apr 24, 2017 8:33 pm

chibios with arduino uno

Postby hackem » Tue Apr 25, 2017 12:24 am

i am windows user. and i m trying to make chibios on arduino uno with Chibios Studio

1) i found a demos on chibios/demo/AVR/ but i don't know how to try it ...


2) under linux i compile it by using command "make"
and after i can't flash it to arduino by "make program" , it doesn't work with usb cable ...


how can i resolve this ..

hackem
Posts: 3
Joined: Mon Apr 24, 2017 8:33 pm

Re: chibios with arduino uno

Postby hackem » Tue Apr 25, 2017 5:25 pm

It's work on linux whit help on IRC channel

1) go to the demos
2) compile whith make
3) flash the arduino uno with make program
When the problem is : can't open device "/dev/ttyACM0
Change the makefile to the device to your arduino device

And it's done

User avatar
tfAteba
Posts: 511
Joined: Fri Oct 16, 2015 11:03 pm
Location: Chartres, France
Has thanked: 75 times
Been thanked: 44 times

Re: chibios with arduino uno

Postby tfAteba » Tue Apr 25, 2017 7:47 pm

Hi again,

Sorry for this evening, I had to leave the IRC because I went to a meating.

Effectively, you had the good reflex, the name of an USB device can differ from a computer to another ( /dev/ttyUSB0, /dev/ttyACM0 and so on...)

The last thing, I will soonly remove all warning that you have seen during the compilation.

Do not hesitate if you have any question.
regards,

Theo.

hackem
Posts: 3
Joined: Mon Apr 24, 2017 8:33 pm

Re: chibios with arduino uno

Postby hackem » Wed Apr 26, 2017 3:47 pm

Thinks ...
It works also with ChibiOS-Arduino https://github.com/greiman/ChibiOS-Arduino with modifying libraries/ChibiOS_AVR/src/utility/chthreads.c at line 397.
Replacing :
void chThdExit(msg_t msg) attribute((used));
With
void chThdExit(msg_t msg) __attribute__((used));

And it's easy to understand exemples

User avatar
tfAteba
Posts: 511
Joined: Fri Oct 16, 2015 11:03 pm
Location: Chartres, France
Has thanked: 75 times
Been thanked: 44 times

Re: chibios with arduino uno  Topic is solved

Postby tfAteba » Wed Apr 26, 2017 7:50 pm

Hi Hackem,

Thanks you for your feedback.

I made modification to remove all warning that was appearing during compilation.

So you can update chibios sources! :)
regards,

Theo.


Return to “AVR Support”

Who is online

Users browsing this forum: No registered users and 3 guests