Makefile problems

ChibiOS public support forum for all topics not covered by a specific support forum.

Moderators: utzig, lbednarz, tfAteba, barthess, RoccoMarco

inmarket
Posts: 89
Joined: Fri Jul 27, 2012 1:37 pm
Location: Brisbane, Australia

Makefile problems

Postby inmarket » Sun Nov 17, 2013 7:22 am

I recently upgraded my Cygwin toolset and the arm compiler toolchain I am using (to 4.7.4). As I also compile for the windows platform and the same problem occurs I suspect the make in the Cygwin toolset.

Since that upgrade I have had continued problems with building.
The first build attempt works fine.
Subsequent build attempts or even a "make clean" result in the error below.
The only solution is to delete the .dep directory. It will then work correctly once (until it recreates the .dep directory).

The error is:

Code: Select all

make clean
.dep/gdisp_lld.o.d:1: *** multiple target patterns.  Stop.


The referenced file is the first alphabetical file that was compiled on the previous compile.

This is driving me batty so I would appreciate any assistance in what might be causing this.

User avatar
Giovanni
Site Admin
Posts: 12949
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 733 times
Been thanked: 609 times
Contact:

Re: Makefile problems

Postby Giovanni » Sun Nov 17, 2013 9:00 am

Hi,

It is the make.exe included in Cygwin, make sure to use a make.exe compiled natively for windoze, for example the one included in mingw or the YAGARTO tools.

Giovanni


Return to “General Support”

Who is online

Users browsing this forum: No registered users and 4 guests