STM32F746G problem to run Topic is solved

ChibiOS public support forum for topics related to the STMicroelectronics STM32 family of micro-controllers.

Moderators: barthess, RoccoMarco

Kubica
Posts: 5
Joined: Thu Mar 28, 2019 7:41 pm

STM32F746G problem to run

Postby Kubica » Thu Mar 28, 2019 7:48 pm

Hi,
I get the error below, if I want to start debug. I read in the forum that other people also have had such an error but no solution helps.
I can flash the device and have no problem with TrueStudio or other IDEs with their toolchain.
I use:
Chibi Studio GCC 7.0
OpenOCD:stm327x6g_eval.cfg and also tried:stm32f7discovery.cfg

with the example
C:\ChibiStudio\chibios191\testhal\STM32\STM32F7xx\USB_RAW

----------------------------------------------------------------------------

symbol-file C:\\ChibiStudio\\chibios191\\testhal\\STM32\\STM32F7xx\\USB_RAW\\build\\ch.elf
Reading symbols from C:\ChibiStudio\chibios191\testhal\STM32\STM32F7xx\USB_RAW\build\ch.elf...done.
set remotetimeout 20
monitor reset init
"monitor" command not supported by this target.
monitor sleep 50
"monitor" command not supported by this target.
load C:\\ChibiStudio\\chibios191\\testhal\\STM32\\STM32F7xx\\USB_RAW\\build\\ch.elf
You can't do that when your target is `None'
tbreak main
Temporary breakpoint 1 at 0x201ce0: file ../../../../os/hal/ports/STM32/STM32F7xx/hal_lld.c, line 120.
continue
The program is not being run.
kill
The program is not being run.

User avatar
Giovanni
Site Admin
Posts: 12949
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 733 times
Been thanked: 609 times
Contact:

Re: STM32F746G problem to run

Postby Giovanni » Fri Mar 29, 2019 9:04 am

Hi,

I need to test it but cannot do it now, you could try to use an older OpenOCD version, it is possible there is a problem with the latest one.

Giovanni

Kubica
Posts: 5
Joined: Thu Mar 28, 2019 7:41 pm

Re: STM32F746G problem to run

Postby Kubica » Fri Mar 29, 2019 9:31 am

I get the following error with ChibiStudio Preview 21 for windows. Do you mean that the OpenOCD can also be the reason here?

Should I install an older version of ChibioStudio or how can this be done to downgrade OpenOCD?

Thanks
Manfred
-----------------------------------------------------

symbol-file C:\\ChibiStudio\\chibios191\\testhal\\STM32\\STM32F7xx\\USB_RAW\\build\\ch.elf
Reading symbols from C:\ChibiStudio\chibios191\testhal\STM32\STM32F7xx\USB_RAW\build\ch.elf...done.
warning: No executable has been specified and target does not support
determining executable automatically. Try using the "file" command.
Reset_Handler () at ../../../../os/common/startup/ARMCMx/compilers/GCC/vectors.S:259
259 b _crt0_entry
monitor reset init
load C:\\ChibiStudio\\chibios191\\testhal\\STM32\\STM32F7xx\\USB_RAW\\build\\ch.elf
Loading section .vectors, size 0x200 lma 0x8000000
Loading section .text, size 0x2e04 lma 0x8000200
Loading section .rodata, size 0x8d0 lma 0x8003004
Loading section .data, size 0x8 lma 0x80038d4
Start address 0x2002d8, load size 14556
Transfer rate: 18 KB/sec, 3639 bytes/write.
tbreak main
Temporary breakpoint 1 at 0x201ce0: file ../../../../os/hal/ports/STM32/STM32F7xx/hal_lld.c, line 120.
continue
Continuing.
Warning:
Cannot insert breakpoint 1.
Cannot access memory at address 0x201ce0

Command aborted.
kill

Kubica
Posts: 5
Joined: Thu Mar 28, 2019 7:41 pm

Re: STM32F746G problem to run

Postby Kubica » Fri Mar 29, 2019 9:58 am

Hi,
I have now replaced the OpenOCD folder in "tools\openocd" with an older version and it runs now.
The version which runs is:
Open On-Chip Debugger 0.10.0+dev-00226-g1c2e3d41d (2017-12-23-10:15)

Best Regards
Manfred

User avatar
Giovanni
Site Admin
Posts: 12949
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 733 times
Been thanked: 609 times
Contact:

Re: STM32F746G problem to run

Postby Giovanni » Fri Mar 29, 2019 11:22 am

OK thanks, it is an OpenOCD issue then. I will plan for a version 22 as soon as possible.

Giovanni

Kubica
Posts: 5
Joined: Thu Mar 28, 2019 7:41 pm

Re: STM32F746G problem to run

Postby Kubica » Fri Mar 29, 2019 2:30 pm

The problem depends also on the hub with which I connect the board. I have two different hubs. Usb 2 and 3. Please take this into account if you fix the problem.

Regards
Manfred

User avatar
RoccoMarco
Posts: 635
Joined: Wed Apr 24, 2013 4:11 pm
Location: Salerno (Italy)
Has thanked: 77 times
Been thanked: 60 times
Contact:

Re: STM32F746G problem to run  Topic is solved

Postby RoccoMarco » Mon Apr 08, 2019 2:00 pm

Hey there,
thanks for posting. We investigated more about this problem and we found out a regression in OpenOCD. I submitted the patch and I will build a new OpenOCD version as soon as the patch would be accepted.

Anyway you can easily fix your OpenOCD by replacing the script
C:\ChibiStudio\tools\openocd\scripts\target\stm32f7x.cfg with the one attached here
stm32f7x.zip
(2.5 KiB) Downloaded 53 times
Ciao,
RM

jscott
Posts: 129
Joined: Tue Jul 03, 2012 3:50 pm
Location: Middle Georgia, USA
Contact:

Re: STM32F746G problem to run

Postby jscott » Thu Dec 05, 2019 10:03 pm

Is this the same problem that causes download and debug problems for the stm32f3 cdc demo?

I am using chibistudio 21 and get...

Code: Select all


symbol-file C:\\ChibiStudio\\workspace_user\\Bubba_Drive_V1\\build\\ch.elf
Reading symbols from C:\ChibiStudio\workspace_user\Bubba_Drive_V1\build\ch.elf...done.
set remotetimeout 20
monitor reset init
"monitor" command not supported by this target.
monitor sleep 50
"monitor" command not supported by this target.
load C:\\ChibiStudio\\workspace_user\\Bubba_Drive_V1\\build\\ch.elf
You can't do that when your target is `None'
tbreak main
Temporary breakpoint 1 at 0x800ac20: file ../../chibios191/os/hal/ports/STM32/STM32F3xx/hal_lld.c, line 110.
continue
The program is not being run.
kill
The program is not being run.



If so, any work on version 22?

-John Scott

P.S. I can download and run the demo with STM32CubeProgrammer
Replacing with openocd-0.10.0-dev-00040-gd52070c did not change anything...

User avatar
Giovanni
Site Admin
Posts: 12949
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 733 times
Been thanked: 609 times
Contact:

Re: STM32F746G problem to run

Postby Giovanni » Fri Dec 06, 2019 9:00 am

Hi,

It will happen after next ChibiOS release. ChibiStudio usually follows.

Giovanni


Return to “STM32 Support”

Who is online

Users browsing this forum: No registered users and 11 guests