ChibiOS crashes when my firmware is not at beginning of flash memory

ChibiOS public support forum for topics related to the STMicroelectronics STM32 family of micro-controllers.

Moderators: barthess, RoccoMarco

kalpesh
Posts: 19
Joined: Mon Dec 09, 2019 11:53 am

Re: ChibiOS crashes when my firmware is not at beginning of flash memory

Postby kalpesh » Wed Mar 11, 2020 5:57 am

Hi,

How to set the VTOR in chibios ?

For HAL application:
I am setting the VTOR in .ld file of the sample application code.

I am only setting flash0 : org = 0x08020000, len = 512k in .ld file of chibios. Also if bootloader jumps to application address, then it starts executing from main ( halinit() and chsysinit() is part of main function). Am I correct ?

Thanks

steved
Posts: 671
Joined: Fri Nov 09, 2012 2:22 pm
Has thanked: 8 times
Been thanked: 96 times

Re: ChibiOS crashes when my firmware is not at beginning of flash memory

Postby steved » Wed Mar 11, 2020 5:40 pm

You also need to set flash1 value in the scatter file; as far as I can remember that's all I did.
Can't remember why, but setting flash0 and flash1 to the same value worked for me.

kalpesh
Posts: 19
Joined: Mon Dec 09, 2019 11:53 am

Re: ChibiOS crashes when my firmware is not at beginning of flash memory

Postby kalpesh » Thu Mar 12, 2020 11:40 am

Hi,

Where is the scatter file located or what is the exact name of this scatter file.

Also do I need to set the same value in flash 1 as I set in flash 0 or some other value.

Thanks


Return to “STM32 Support”

Who is online

Users browsing this forum: No registered users and 3 guests