OpenOCD error messages with ChibiOS detection

Discussions and support about ChibiStudio, the free development environment for ARM.
Dwar
Posts: 12
Joined: Fri Jan 08, 2016 2:04 pm
Location: USA
Has thanked: 4 times
Been thanked: 3 times

OpenOCD error messages with ChibiOS detection

Postby Dwar » Sat Mar 05, 2016 5:46 am

I'm having problems with the Chibi debug plugin with Preview16. Not seeing any information when I open the Eclipse debug plugin for 3.x.x.
I turned on all Debug options in chconf.h and compiled with -O0. I can step thru the code and use gdb normally but no ChibiOS debug info.

OpenOCD invocation:

-c "telnet_port 4444" -s "C:\ChibiStudio\tools\openocd\scripts" -f "interface/stlink-v2-1.cfg" -f "board/stm32f4discovery.cfg" -c "stm32f4x.cpu configure -rtos ChibiOS"

In the debug messages for openocd I see the error messages:

Info : 2459 40032 ChibiOS.c:202 ChibiOS_update_memory_signature(): Successfully loaded memory map of ChibiOS/RT target running version 3.0.3
Debug: 2460 40032 hla_target.c:752 adapter_read_memory(): adapter_read_memory 0x20000888 4 1
Debug: 2461 40036 target.c:2224 target_read_u32(): address: 0x20000888, value: 0x00000000
Error: 2462 40036 ChibiOS.c:332 ChibiOS_update_threads(): ChibiOS registry integrity check failed, NULL pointer
Info : 2463 40036 ChibiOS.c:355 ChibiOS_update_threads(): Only showing current execution because of a broken ChibiOS thread registry.
Debug: 2464 40037 gdb_server.c:2673 gdb_input_inner(): received packet: 'qSymbol::'
Debug: 2465 40037 gdb_server.c:2673 gdb_input_inner(): received packet: 'qSymbol::726c697374'
Debug: 2466 40037 gdb_server.c:2673 gdb_input_inner(): received packet: 'qSymbol:20000878:6368'
Debug: 2467 40037 gdb_server.c:2673 gdb_input_inner(): received packet: 'qSymbol:8006140:63685f6465627567'
Debug: 2468 40037 gdb_server.c:2673 gdb_input_inner(): received packet: 'qSymbol:8004560:6368537973496e6974'
Debug: 2469 40037 hla_target.c:752 adapter_read_memory(): adapter_read_memory 0x20000888 4 1
Debug: 2470 40040 target.c:2224 target_read_u32(): address: 0x20000888, value: 0x00000000
Error: 2471 40040 ChibiOS.c:332 ChibiOS_update_threads(): ChibiOS registry integrity check failed, NULL pointer
Info : 2472 40040 ChibiOS.c:355 ChibiOS_update_threads(): Only showing current execution because of a broken ChibiOS thread registry.

User avatar
Giovanni
Site Admin
Posts: 13121
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 769 times
Been thanked: 653 times
Contact:

Re: OpenOCD error messages with ChibiOS detection

Postby Giovanni » Sat Mar 05, 2016 7:20 am

Hi,

Try executing the code past chSysInit(), the threads list is not initialized before that so info cannot be retrieved.

Giovanni

Dwar
Posts: 12
Joined: Fri Jan 08, 2016 2:04 pm
Location: USA
Has thanked: 4 times
Been thanked: 3 times

Re: OpenOCD error messages with ChibiOS detection

Postby Dwar » Sat Mar 05, 2016 8:51 am

I ran it well past chSysInit(). Still no Debug info with the ChibiOS plugin.


See these several times:

Error: 2964 58014 ChibiOS.c:332 ChibiOS_update_threads(): ChibiOS registry integrity check failed, NULL pointer
Info : 2965 58014 ChibiOS.c:355 ChibiOS_update_threads(): Only showing current execution because of a broken ChibiOS thread registry.

User avatar
Giovanni
Site Admin
Posts: 13121
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 769 times
Been thanked: 653 times
Contact:

Re: OpenOCD error messages with ChibiOS detection

Postby Giovanni » Sat Mar 05, 2016 9:54 am

It is possible you got a stack overflow and the registry is corrupt.

Giovanni

Dwar
Posts: 12
Joined: Fri Jan 08, 2016 2:04 pm
Location: USA
Has thanked: 4 times
Been thanked: 3 times

Re: OpenOCD error messages with ChibiOS detection

Postby Dwar » Sat Mar 05, 2016 11:21 am

I see the same result when I run the unmodified demo RT-STM32F407-DISCOVERY with the F4 Discovery board (except for the chconf.h debugs and the Makefile -O0). I do see thread info from the "info threads" command but still nothing from the ChibiOS plugin.


With all the debugs turned on would a stack overflow not result in some sort of error message? Anything I else I could investigate?

Thanks!
--dave

User avatar
Giovanni
Site Admin
Posts: 13121
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 769 times
Been thanked: 653 times
Contact:

Re: OpenOCD error messages with ChibiOS detection

Postby Giovanni » Sat Mar 05, 2016 12:07 pm

You could verify if the Eclipse ChibiOS debug plugin (in ChibiStudio) is able to enumerate the threads.

If it is able then it is a problem in OpenOCD else there must be some memory corruption.

Giovanni

Dwar
Posts: 12
Joined: Fri Jan 08, 2016 2:04 pm
Location: USA
Has thanked: 4 times
Been thanked: 3 times

Re: OpenOCD error messages with ChibiOS detection

Postby Dwar » Sat Mar 05, 2016 12:33 pm

I've attached a screen capture. The Eclipse ChibiOS debug plugin doesn't show any thread information.
Attachments
ChibiDebug.png

User avatar
Giovanni
Site Admin
Posts: 13121
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 769 times
Been thanked: 653 times
Contact:

Re: OpenOCD error messages with ChibiOS detection

Postby Giovanni » Sat Mar 05, 2016 3:22 pm

You need to refresh the view in order to see anything, see the button on the right.

Giovanni

Dwar
Posts: 12
Joined: Fri Jan 08, 2016 2:04 pm
Location: USA
Has thanked: 4 times
Been thanked: 3 times

Re: OpenOCD error messages with ChibiOS detection

Postby Dwar » Sat Mar 05, 2016 4:02 pm

The refresh button did the trick.

Thank you Giovanni!


Return to “ChibiStudio”

Who is online

Users browsing this forum: No registered users and 5 guests