Use Chibistudio with STM32L475VCT6

Discussions and support about ChibiStudio, the free development environment for ARM.
sprehse
Posts: 2
Joined: Thu May 21, 2020 2:59 pm
Been thanked: 1 time

Use Chibistudio with STM32L475VCT6

Postby sprehse » Thu May 21, 2020 3:18 pm

Hello everyone
I have a question about flashing STM32 controllers

I have created a project on a Nucleo64-L476RG and now I want to flash the program on an STM32L475VCT6. Unfortunately I do not know exactly whether it is possible at all and if so at which points in the config I have to make adjustments.
In addition, I use an ST-Link v2 to flash the L475, now. Starting the openocd with the L4-nucleo.cfg was correct or not?
I tried to flash the code but I got this message in the console window.

symbol-file C:\\ChibiStudio\\workspace_user\\SW_Slave_V2\\build\\ch.elf
Reading symbols from C:\ChibiStudio\workspace_user\SW_Slave_V2\build\ch.elf...done.
warning: No executable has been specified and target does not support
determining executable automatically. Try using the "file" command.
0x0800168e in stm32_clock_init () at ../../chibios191/os/hal/ports/STM32/STM32L4xx/hal_lld.c:239
239 while ((RCC->BDCR & RCC_BDCR_LSERDY) == 0)
monitor reset init
monitor sleep 50
load C:\\ChibiStudio\\workspace_user\\SW_Slave_V2\\build\\ch.elf
Loading section .vectors, size 0x1a0 lma 0x8000000
Loading section .text, size 0x6650 lma 0x80001a0
Loading section .rodata, size 0x5a0 lma 0x80067f0
Loading section .data, size 0x268 lma 0x8006d90
Start address 0x8000278, load size 28664
Transfer rate: 28 KB/sec, 5732 bytes/write.
tbreak main
Temporary breakpoint 1 at 0x80050c4: file main.c, line 47.
continue
Continuing.
Note: automatically using hardware breakpoints for read-only addresses.
Exception condition detected on fd 672
Remote communication error. Target disconnected.: No such file or directory.
Quit
Quit

Greetings.

User avatar
Giovanni
Site Admin
Posts: 12744
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 693 times
Been thanked: 572 times
Contact:

Re: Use Chibistudio with STM32L475VCT6

Postby Giovanni » Thu May 21, 2020 7:13 pm

Hi,

Are you using the latest ChibiStudio? it includes a tool to generate debug configurations automatically:

viewtopic.php?f=7&t=2119&start=10#p37668

Using L4-nucleo config is correct.

Giovanni

sprehse
Posts: 2
Joined: Thu May 21, 2020 2:59 pm
Been thanked: 1 time

Re: Use Chibistudio with STM32L475VCT6

Postby sprehse » Fri May 22, 2020 11:04 am

Hey Giovanni,
thanks for the reply.
No i have used the previous Verison of ChibiOS.
So i have update now and use the debug generation tool. It works now.
Thank you :).


Return to “ChibiStudio”

Who is online

Users browsing this forum: No registered users and 1 guest