Compile with Make on WSL

Discussions and support about ChibiStudio, the free development environment for ARM.
JSStabl
Posts: 54
Joined: Tue Feb 25, 2020 4:06 pm
Been thanked: 1 time

Compile with Make on WSL

Postby JSStabl » Fri Feb 28, 2020 10:42 am

I'm trying to setup to compile my chibiOS project to comile with make (and eventually cmake) from my wsl bash. I'm using a modified version of the newest example for the

Code: Select all

RT-STM32F767ZI-NUCLEO144


Now, when I go to the project directory and simply type make -j8 (as i is in chibiOS), I get

Code: Select all

.dep/hal_spi.o.d:1: *** multiple target patterns.  Stop.


I assume theres something missing on my toolchain. I was able to compile a different chibiOS project (the vesc firmware) with this method though.

Are there any settings I need to set before I can compile this? Couldn't fine any in eclipse itself. Googling the issue brings up spaces in the path (which i dont have) and some other weird issues, but since it compiles fine in chibiStudio (under windows) it's probably a configuration issue.

I'm using make version 4.1 and my gcc is on 7.4.0.

JSStabl
Posts: 54
Joined: Tue Feb 25, 2020 4:06 pm
Been thanked: 1 time

Re: Compile with Make on WSL

Postby JSStabl » Fri Feb 28, 2020 12:45 pm

Solved, compiled under windows beforehand. Delete the .dep and run make clean. Then it compiles under ubuntu with make 4.2.1.

User avatar
Giovanni
Site Admin
Posts: 12943
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 729 times
Been thanked: 609 times
Contact:

Re: Compile with Make on WSL

Postby Giovanni » Fri Feb 28, 2020 1:58 pm

Make sure to use GNU make, the one from MinGW is fine.

Giovanni


Return to “ChibiStudio”

Who is online

Users browsing this forum: No registered users and 1 guest