Can't build board files, no configuration wizard

Discussions and support about ChibiStudio, the free development environment for ARM.
faisal
Posts: 201
Joined: Wed Jul 19, 2017 12:44 am
Has thanked: 30 times
Been thanked: 25 times

Can't build board files, no configuration wizard

Postby faisal » Fri Feb 23, 2018 8:21 pm

Using ChibiStudio_Preview19.7z straight from sourceforge.

I can't seem to figure out how to build board files. Apparently, there is supposed to be an icon in the toolbar to build the board file after you have highlighted the .chcfg file or opened it up. Attached is a screenshot of what I see.

Also, opening the .chcfg file doesn't open in an XML editor. Even when right-clicking it there was no option to open in the XML editor. I had to go in preferences to add *.chcfg as an accepted type for the XML editor.

I have also read there is a configuration wizard to generate a project or at least board files. Where is it? Also, for editing the .chcfg file, are there any validation rules which allow you to choose acceptable values from a drop down or something? Looking at the .xsd files in the plugin source - that should be possible. Something seems off, and I'm not getting the whole ChibiStudio experience. Could there be a configuration issue? I tried using the standard workspaces that come with ChibiStudio.
Attachments
screenshot.png

User avatar
Giovanni
Site Admin
Posts: 11380
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 430 times
Been thanked: 361 times
Contact:

Re: Can't build board files, no configuration wizard

Postby Giovanni » Fri Feb 23, 2018 10:06 pm

You should select the .chcfg file in the project explorer then the button should appear, it is very noticeable because the whole toolbar shifts a bit when that happens.

Being unable to open the file in the XML editor makes me think there is a more general problem, that is enforced by the ChibiStudio plugins. Probably this is why you don't see the button too.

Make sure to unzip the file with the antivirus disabled, sometime it can create problems, it happened in the past. Also make sure you have Java 32 bits.

Giovanni

faisal
Posts: 201
Joined: Wed Jul 19, 2017 12:44 am
Has thanked: 30 times
Been thanked: 25 times

Re: Can't build board files, no configuration wizard

Postby faisal » Fri Feb 23, 2018 10:54 pm

Thanks, both of those steps helped. Now when I double click on the board.chcfg, it opens up in the XML editor, and I see the Generate Files from Configuration Data. All seems to work :) .

I do have a question. How does the XML editor know the enumerations for each field? Those are stored in gencfg/schema/boards/.xsd , and I don't see any path configured in the .chcfg files which references that. The only reference to the _board.xsd is the xsi:noNamespaceSchemaLocation, which is a reference to http://www.chibios.org/xml/schema/board ... _board.xsd (and nothing is at that link).

Edit: I found it, XML Catalog :).

User avatar
Giovanni
Site Admin
Posts: 11380
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 430 times
Been thanked: 361 times
Contact:

Re: Can't build board files, no configuration wizard

Postby Giovanni » Sat Feb 24, 2018 7:26 am

Correct, it is an Eclipse mechanism to override specific URLs for schemas.

Giovanni


Return to “ChibiStudio”

Who is online

Users browsing this forum: No registered users and 2 guests