Eclipse Luna + linux - Container for the resource not selected

Discussions and support about ChibiStudio, the free development environment for ARM.
phofman
Posts: 8
Joined: Sat Apr 29, 2017 3:26 pm

Eclipse Luna + linux - Container for the resource not selected

Postby phofman » Sat Apr 29, 2017 3:35 pm

Hi,

I am new to chibiOS and would love to develop STM32 on linux (Mint 18 64bit). I downloaded 64-bit Eclipse Luna SR2 C++ version from eclipse site (I saw the latest ChibiStudio is based on Luna), installed the chibios plugins from the chibios plugins repository http://www.chibios.org/eclipse/chibistudio. When trying to run the chibios wizard, I keep getting the error "Container for the resource not selected". I saw this issue discussed here 5 years ago viewtopic.php?t=692 with no actual result.

JRE Oracle Java 8

Thank you very much for any help.

Best regards,

Pavel.

User avatar
Giovanni
Site Admin
Posts: 9815
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 159 times
Been thanked: 144 times
Contact:

Re: Eclipse Luna + linux - Container for the resource not selected

Postby Giovanni » Sat Apr 29, 2017 4:19 pm

Hi,

That feature is still broken but it is not required, in order to start a new project please follow the procedure in this video:

https://www.youtube.com/watch?v=pjOhxBA9L3s

BTW, I am running Eclipse Mars under Mint 18, no problems except that one.

Giovanni

phofman
Posts: 8
Joined: Sat Apr 29, 2017 3:26 pm

Re: Eclipse Luna + linux - Container for the resource not selected

Postby phofman » Sat Apr 29, 2017 4:28 pm

Giovanni, thanks a lot for the quick help.

I will follow the video now.

Best regards,

Pavel.

phofman
Posts: 8
Joined: Sat Apr 29, 2017 3:26 pm

Re: Eclipse Luna + linux - Container for the resource not selected

Postby phofman » Sat Apr 29, 2017 5:41 pm

Please is there an example of linux eclipse configuration for chibios on stm32? That video is very good for importing existing code into the fully configured eclipse in chibistudio. I understand making screenshots takes a lot of time (that is why I prefer command line), perhaps a working config I could diff with my files for changes... or just a link with working config description for linux.

I think I have all the packages installed but configuring the build chain in eclipse is a different story.

I very much appreciate any help. I think such info would be useful for many other linux users wanting to delve into chibios on the very inexpensive stm32 boards available.

phofman
Posts: 8
Joined: Sat Apr 29, 2017 3:26 pm

Re: Eclipse Luna + linux - Container for the resource not selected

Postby phofman » Sat Apr 29, 2017 5:58 pm

Actually it does not have to be for linux, the difference between OSes are just paths, easily fixable. Only all the tutorials I was able to find start with downloading the fully configured eclipse being part of chibistudio for windows.

Thanks a lot for considering.


Return to “ChibiStudio”

Who is online

Users browsing this forum: No registered users and 1 guest