Search found 57 matches

by JSStabl
Thu Mar 12, 2020 2:52 pm
Forum: ChibiOS/HAL
Topic: SPIv3 issues
Replies: 18
Views: 3116

Re: SPIv3 issues

Are you referring to testhal\STM32\multi\SPI? Just discovered that instead of having STMxx_SPI they where now grouped under "multi" (sneaky :)). Tried to compile the "build for STM32H743", chose the ch.elf in the debug config manually and flashed it. Correction: I get some output...
by JSStabl
Thu Mar 12, 2020 11:29 am
Forum: ChibiOS/HAL
Topic: SPIv3 issues
Replies: 18
Views: 3116

Re: SPIv3 issues

I'm also dealing with issues with the H743 and SPI. With ChibiOS 19.1.3 there was no output at all and the spi_send was stuck after 3 or 4 iterations. I updated to the latest trunk (from github), fixed my mcuconf and chconf and now I get an output but it looks very weird: h743_weird_spi.png I attach...
by JSStabl
Wed Mar 11, 2020 3:47 pm
Forum: Bug Reports
Topic: STM32H743 PAL WAIT Topic is solved
Replies: 5
Views: 1647

Re: STM32H743 PAL WAIT Topic is solved

Seems to fix it thanks!
by JSStabl
Wed Mar 11, 2020 2:58 pm
Forum: Bug Reports
Topic: STM32H743 PAL WAIT Topic is solved
Replies: 5
Views: 1647

Re: STM32H743 PAL WAIT Topic is solved

I downloaded ChibiStudio around two weeks ago and I'm using the included ChibiOS 19.1.1 stable.
by JSStabl
Wed Mar 11, 2020 10:46 am
Forum: Bug Reports
Topic: STM32H743 PAL WAIT Topic is solved
Replies: 5
Views: 1647

Re: STM32H743 PAL WAIT Topic is solved

After some digging:

Adding #define STM32_EXTI_ENHANCED to mcuconf.h fixes the issues. Unsure if thats the right place to go. ArduPilot does it the same way.
https://github.com/ArduPilot/ardupilot/ ... _mcuconf.h
by JSStabl
Wed Mar 11, 2020 10:10 am
Forum: Bug Reports
Topic: STM32H743 PAL WAIT Topic is solved
Replies: 5
Views: 1647

STM32H743 PAL WAIT Topic is solved

The STM32H743 seems to have an issue with the PAL WAIT Drivers. To reproduce go to: chibios191/demos/STM32/RT-STM32H743I-NUCLEO144 set /** * @brief Enables synchronous APIs. * @note Disabling this option saves both code and data space. */ #if !defined(PAL_USE_CALLBACKS) || defined(__DOXYGEN__) #defi...
by JSStabl
Thu Mar 05, 2020 4:28 pm
Forum: ChibiOS/RT
Topic: Starting up/Resuming Threads
Replies: 3
Views: 760

Re: Starting up/Resuming Threads

Understood. Seems like a bunch overhead for my "init" thread though. Meaning I have to actively keep sending semaphores/events in order for the threads to keep running, that takes computing. What I'm looking for is more of an enable/disable flag. Using a regular global boolean flag set by ...
by JSStabl
Thu Mar 05, 2020 2:13 pm
Forum: ChibiOS/RT
Topic: Starting up/Resuming Threads
Replies: 3
Views: 760

Starting up/Resuming Threads

I have a system where I have a bunch of threads that are running when i'm in steady state operation. However when the device is started I don't want them to be running, I would have an init thread that checks a bunch of things on periphery and then starts up the other tasks/threads. I also want to b...
by JSStabl
Wed Mar 04, 2020 2:55 pm
Forum: Bug Reports
Topic: Getting SPI to work on STM32F7 Topic is solved
Replies: 21
Views: 3659

Re: Getting SPI to work on STM32F7 Topic is solved

We seem to be talking about different things :) I am aware that one SPI instance (e.g. SPI1) can't be used at the same time, however SPI1 and SPI2 can run very close to each other (see the image below). So my use case is: High Priority Path: GPIO Interrupt -> SPI5 Exchange -> SPI1/2/3 send (<---- as...
by JSStabl
Wed Mar 04, 2020 2:10 pm
Forum: Bug Reports
Topic: Getting SPI to work on STM32F7 Topic is solved
Replies: 21
Views: 3659

Re: Getting SPI to work on STM32F7 Topic is solved

The STM32F7xx-SPI Demo was my starting point, however all the threads there are executed synchronously (spiSend/Exchange). However I need my 3 SPIs to fire as fast as possible after the high-prio thread finished, as well have a slower, async messages on that bus. If I execute my spiSend synchronousl...

Go to advanced search