Search found 57 matches

by JSStabl
Fri May 15, 2020 10:18 am
Forum: Development and Feedback
Topic: [DISASTER] Web site gone
Replies: 10
Views: 538

Re: [DISASTER] Web site gone

Hmm that depends how you wrote the book, did you write it directly in HTML or use Latex or some other tool?

If the former, Rauls suggestions is probably the best approach for the mean time :)

If you send me the HTML I can take care of it.
by JSStabl
Fri May 15, 2020 8:58 am
Forum: Development and Feedback
Topic: [DISASTER] Web site gone
Replies: 10
Views: 538

Re: [DISASTER] Web site gone

Would you maybe have a pdf copy of the chibiOS book in the meantime? :)
by JSStabl
Fri May 15, 2020 8:55 am
Forum: User Projects
Topic: Howto: CLion and ChibiOS
Replies: 4
Views: 1922

Re: Howto: CLion and ChibiOS

I'm in contact with them. They promised to have a beta some time this year :)

Interesting project, not entirely sure how that works yet, since chibiOS is makefile based :)
by JSStabl
Fri May 15, 2020 8:54 am
Forum: ChibiStudio
Topic: Updating Project from older ChibiStudio version
Replies: 7
Views: 366

Re: Updating Project from older ChibiStudio version

Right. RTFM...

Still didnt get it work but updated my old launch file so thats fine :)
by JSStabl
Thu May 14, 2020 2:50 pm
Forum: ChibiStudio
Topic: Updating Project from older ChibiStudio version
Replies: 7
Views: 366

Re: Updating Project from older ChibiStudio version

Hmm, i got the launch file generator working (by clicking it repeatedly). Now I get a different error: Error in final launch sequence: Failed to execute MI command: symbol-file C:/ChibiStudio/workspace_user/SW_Master_v2/debug Error message from debugger back end: C:/ChibiStudio/workspace_user/SW_Mas...
by JSStabl
Thu May 14, 2020 2:35 pm
Forum: ChibiStudio
Topic: Updating Project from older ChibiStudio version
Replies: 7
Views: 366

Updating Project from older ChibiStudio version

I tried to move my project from Chibi Studio Preview 21 to the newest version and am encountering some issues. When I use my existing .launch file in /debug I get the error: Error in final launch sequence: Reset command not defined for device 'Generic TCP/IP' Reset command not defined for device 'Ge...
by JSStabl
Thu May 14, 2020 8:40 am
Forum: ChibiOS/RT
Topic: Strings to mailboxes
Replies: 15
Views: 737

Re: Strings to mailboxes

Yeah, that was it, thanks :)
by JSStabl
Wed May 13, 2020 3:48 pm
Forum: ChibiOS/RT
Topic: Strings to mailboxes
Replies: 15
Views: 737

Re: Strings to mailboxes

Neat, thanks! I see to have a general issue with using mailboxes defined in other c files though. When I define: static mailbox_t state_mb; static msg_t state_mb_buffer[10]; In my header file and then initialize the Mailbox from the same c file, I can post messages to it from within that same c file...
by JSStabl
Wed May 13, 2020 3:31 pm
Forum: ChibiOS/RT
Topic: Strings to mailboxes
Replies: 15
Views: 737

Re: Strings to mailboxes

Isnt the chprintf function blocking? If not that could be a solution as well. Need to take care of syslock like you did though. Hmmm, weird. If I do this it works: THD_WORKING_AREA(serial_output_thread_wa, 256); THD_FUNCTION(serial_output_thread, arg) { (void)arg; chRegSetThreadName("Uart Comm ...
by JSStabl
Wed May 13, 2020 2:06 pm
Forum: ChibiOS/RT
Topic: Strings to mailboxes
Replies: 15
Views: 737

Re: Strings to mailboxes

Thanks steve! Looks really interesting, I would keep the Mailbox logic, since I don't want to interrupt any fast threads with a blocking write. I'm thinking about using sprintf and then pushing that to the mailbox q. Only thing I need to figure out what to do when the thread isn't running yet (i.e. ...

Go to advanced search