Search found 15 matches

by Xela
Mon Oct 09, 2017 2:35 pm
Forum: General Support
Topic: Advice on filesystem organisation
Replies: 4
Views: 1298

Re: Advice on filesystem organisation

Great! thank you very much. I'm still very "hello world" at this point and I'm trying to get LED, USB, IMU up running first with HAL then RTOS. I will be moving to some more complex devices such as LORA and UWB at some point, but perhaps i'll wait until then before getting into an appropri...
by Xela
Mon Oct 09, 2017 2:01 pm
Forum: General Support
Topic: Advice on filesystem organisation
Replies: 4
Views: 1298

Re: Advice on filesystem organisation

Ok so let's see if I understand this using the Invensense mpu-9250 IMU as an example. I would put the low level driver devices specifics files in ex/Invensense/mpu9250.h ... mpu9250.h ... mpu9250.mk This is an I2C devices so it is a complex driver interfacing to hal/src/hal_12c.c In hal/lib/sensor/ ...
by Xela
Thu Oct 05, 2017 11:14 am
Forum: General Support
Topic: Advice on filesystem organisation
Replies: 4
Views: 1298

Advice on filesystem organisation

I am working to bring up a board with a variety of components, LORA, UWB, IMU etc.. so I am writing drivers and would like to follow the existing structure for doing so. I understand the architecture, I'd say most of my components will be complex drivers making use of existing peripheral drivers and...
by Xela
Fri Sep 22, 2017 3:46 pm
Forum: ChibiStudio
Topic: Generate files from configuration data does nothing.
Replies: 15
Views: 3234

Generate files from configuration data does nothing.

I have recently setup Eclipse Mars under linux (Ubuntu 14.04) and have installed the chibiStudio plugin, XML editor, CDT. I have been tinkering with the STM32F407 discovery board. Everything seems to go smoothly now, I can modify code, upload it to the board, debug etc. Now it is time to move to my ...
by Xela
Tue Sep 19, 2017 4:38 pm
Forum: ChibiStudio
Topic: Chibi Eclipse plugin not working under Eclipse Neon
Replies: 17
Views: 5624

Re: Chibi Eclipse plugin not working under Eclipse Neon

Hi All I am new to this community, trying to figure out how to bring up a new board with chibi. I have run into the same problem here. I believe I am on Eclipse Oxygen. Not sure how to proceed without these chibi tools in eclipse. It will break my heart to set up a windows machine. There really is n...

Go to advanced search