Search found 199 matches

by pito
Mon Oct 14, 2013 9:31 am
Forum: ChibiStudio
Topic: Terminal and BT
Replies: 2
Views: 1643

Re: Terminal and BT

I can write down the com4 and com6 into the COM selection box in the Terminal1 settings window, but it returns "no such port.." when trying to connect actually - see below. It also locks the com4 driver down so I cannot open the com4 w/ the TeraTerm after such above attempt (I have to powe...
by pito
Sun Oct 13, 2013 7:23 pm
Forum: ChibiStudio
Topic: Terminal and BT
Replies: 2
Views: 1643

Terminal and BT

I am using BT modules for comm with my discoboards. When trying the built-in Terminal1 (CBS5), ie. com4 or com6 (my two BT modules) it says no coms, and locks them, so even TeraTerm says coms are not available. Disconnecting/connecting the st-link helps (so TT can use them again). Any hint how to se...
by pito
Wed Oct 09, 2013 12:16 pm
Forum: STM32 Support
Topic: CB3.0 F100 - I2C issues
Replies: 19
Views: 4147

Re: CB3.0 F100 - I2C issues

Including the following code into my source causes the system halts around i2cstart (it works in trunk).. If somebody may see an issue below, give me a hint , plz :x .. #include "chTinyRTC8563.h" .. static const I2CConfig i2cfg1 = {OPMODE_I2C, 400000, FAST_DUTY_CYCLE_16_9}; //40Mhz clock ....
by pito
Tue Oct 08, 2013 8:52 pm
Forum: STM32 Support
Topic: CB3.0 F100 - I2C issues
Replies: 19
Views: 4147

Re: CB3.0 F100 - I2C issues

Chibi30\os\hal\ports\STM32\I2Cv1\i2c_lld.c

l.146

Code: Select all

 osalDbgCheck((i2cp != NULL) &&
               (clock_speed > 0) &&
               (clock_speed <= 4000000));  <<<< Typo
by pito
Tue Oct 08, 2013 7:55 pm
Forum: STM32 Support
Topic: CB3.0 F100 - I2C issues
Replies: 19
Views: 4147

Re: CB3.0 F100 - I2C issues

Ah, yea, tickless mode requires a hw counter.. thanks.
The next step is the I2c..
by pito
Tue Oct 08, 2013 7:38 pm
Forum: STM32 Support
Topic: CB3.0 F100 - I2C issues
Replies: 19
Views: 4147

Re: CB3.0 F100 - I2C issues

I have a task, which does: static THD_WORKING_AREA (waThread1, 128); static THD_FUNCTION (Thread1, arg) { (void)arg; chRegSetThreadName("counter"); // Time for next read. systime_t wakeTime = chVTGetSystemTimeX(); while (TRUE) { wakeTime += 10; chThdSleepUntil(wakeTime); seconds_counter++;...
by pito
Tue Oct 08, 2013 7:13 pm
Forum: STM32 Support
Topic: CB3.0 F100 - I2C issues
Replies: 19
Views: 4147

Re: CB3.0 F100 - I2C issues

It started to work somehow, but: 1. when I2C stuff enabled it crashes in an unhandled exception (I will investigate) 2. getting compile error: 'RDY_OK' undeclared here (not in a function) usually returned by i2cMasterTransmitTimeout() - is being lost somewhere, so I have to def it in my source as 0 ...
by pito
Mon Oct 07, 2013 10:56 am
Forum: STM32 Support
Topic: CB3.0 F100 - I2C issues
Replies: 19
Views: 4147

Re: CB3.0 F100 - I2C issues

LTO disabled: text data bss dec hex filename 17364 428 4528 22320 5730 build/ch.elf 2kB less, do I miss something there? Still hangs on the I2C.. I removed the I2C stuff, printing some adc values and systime, ( with spi, adc, and pwm chunks from demos) in a loop. It does few loops, prints, then stop...
by pito
Mon Oct 07, 2013 8:44 am
Forum: STM32 Support
Topic: CB3.0 F100 - I2C issues
Replies: 19
Views: 4147

Re: CB3.0 F100 - I2C issues

In RT-STMF100-DISCOVERY there is probably wrong def MCU = cortex-m4 What I do not understand yet is my compiled code under 3.0 is 5kB smaller than with trunk.. :shock: 3.0: text data bss dec hex filename 14384 428 4528 19340 4b8c build/ch.elf trunk: text data bss dec hex filename 19492 356 4416 2426...
by pito
Sun Oct 06, 2013 9:11 pm
Forum: STM32 Support
Topic: CB3.0 F100 - I2C issues
Replies: 19
Views: 4147

Re: CB3.0 F100 - I2C issues

As indicated above: Thread [1] (Suspended: Signal 'SIGINT' received. Description: Interrupt.) 7 chSysHalt() core_cmFunc.h:342 0x08002e1c 6 _dbg_check_lock() chdebug.c:119 0x08002e1c 5 chSysLock() chsys.h:290 0x0800324c 4 i2c_lld_master_transmit_timeout() osal.h:377 0x0800324c 3 i2cMasterTransmitTime...

Go to advanced search