Search found 197 matches

by FXCoder
Fri Sep 20, 2019 12:55 pm
Forum: Development and Feedback
Topic: [DEV] STM32G4xx support
Replies: 27
Views: 1171

Re: [DEV] STM32G4xx support

Hi, The last opened windows/Linux set I built for G0 support used a cherry-picked dedicated G0 variant patch that didn't include G4 support. There is another patch in gerrit which has been in progress for quite some months which modifies the L4 driver to include both G0 and G4. It isn't through revi...
by FXCoder
Thu Sep 12, 2019 2:03 pm
Forum: Bug Reports
Topic: hal_lld for F413 change to enable select of PLLI2S for CK48 Topic is solved
Replies: 6
Views: 538

Re: hal_lld for F413 change to enable select of PLLI2S for CK48 Topic is solved

Hi, Finally got back to check this on an F413 project. Below fixes to: 1. Handle specfifying STM32_CK48MSEL_PLLI2S in mcuconf.h clock setting 2. Handle that F413 has no PLLI2SP bit. -- Bob ### Eclipse Workspace Patch 1.0 #P chibios_trunk Index: os/hal/ports/STM32/STM32F4xx/hal_lld.h ================...
by FXCoder
Sat Aug 31, 2019 8:14 am
Forum: Bug Reports
Topic: chprintf() - float precision Topic is solved
Replies: 5
Views: 309

Re: chprintf() - float precision Topic is solved

Hi Steve,
FYI you are missing another change in the source submitted.
See this post.
--
Bob
by FXCoder
Tue Aug 06, 2019 1:50 pm
Forum: Development and Feedback
Topic: [INFO] ChibiStudio P2 preinstalled into Linux Mint 19.2 VM
Replies: 11
Views: 501

Re: [INFO] ChibiStudio P2 preinstalled into Linux Mint 19.2 VM

Hi,
The Egit add-on works pretty well in Eclipse.
SVN should already be part of the C/C++ Eclipse package?
--
Bob
by FXCoder
Thu Jul 11, 2019 2:06 pm
Forum: ChibiStudio
Topic: ChibiStudio, Windows 10 and several problems....
Replies: 12
Views: 604

Re: ChibiStudio, Windows 10 and several problems....

GNU MCU Eclipse is also worthy of consideration.
Certainly nice to be able to set a different toolchain per project.
--
Bob
by FXCoder
Thu Jul 11, 2019 1:52 pm
Forum: ChibiStudio
Topic: ChibiStudio, Windows 10 and several problems....
Replies: 12
Views: 604

Re: ChibiStudio, Windows 10 and several problems....

An update...
The version of Eclipse I have on the Mac is Oxygen.3a Release (4.7.3a).

The debug configuration allows for combined launch of opened and start of debug.
That's the magic.
--
Bob
by FXCoder
Wed Jul 10, 2019 11:01 am
Forum: ChibiStudio
Topic: ChibiStudio, Windows 10 and several problems....
Replies: 12
Views: 604

Re: ChibiStudio, Windows 10 and several problems....

Hi, I’ve done a launch configuration as described on an older Macbook Air but not on Windows. The Eclipse setup on the Mac also uses GNU MCU to set toolchain per project. Quite good to use once the settings get sorted out (a bit fiddly). Not home ATM but will look ASAP and advise any salient points....
by FXCoder
Sun Jul 07, 2019 6:31 am
Forum: Bug Reports
Topic: Update wiki Topic is solved
Replies: 2
Views: 131

Re: Update wiki Topic is solved

Agreed best to retire it ASAP.
There is still SF info on that page BTW (at the top).
by FXCoder
Sun Jul 07, 2019 5:03 am
Forum: Bug Reports
Topic: Update wiki Topic is solved
Replies: 2
Views: 131

Update wiki Topic is solved

Wiki page still shows SF as repository versus new location at OSDN.

Go to advanced search