Search found 526 matches

by tfAteba
Thu Nov 05, 2015 12:07 am
Forum: General Support
Topic: ChibiOS RT Test Suit Problem! Topic is solved
Replies: 5
Views: 1309

Re: ChibiOS RT Test Suit Problem! Topic is solved

Hi, It is very strange, after reading http://chibios.org/dokuwiki/doku.php?id=chibios:articles:debug_guide I started by enabling the debug option CH_DBG_SYSTEM_STATE_CHECK and I also changed the GCC optimization level to -o0, recompile and flash the board. After that the Test succeed. So I came back...
by tfAteba
Wed Nov 04, 2015 11:06 pm
Forum: General Support
Topic: ChibiOS RT Test Suit Problem! Topic is solved
Replies: 5
Views: 1309

Re: ChibiOS RT Test Suit Problem! Topic is solved

Hi,

I'm going to read the about ChibiOS debuging first and see about the problem.

Can you try to reproduce the problem with your board? I'm using the STM32F401RE Nucleo.

Theo.
by tfAteba
Tue Nov 03, 2015 11:02 pm
Forum: General Support
Topic: ChibiOS RT Test Suit Problem! Topic is solved
Replies: 5
Views: 1309

Re: ChibiOS RT Test Suit Problem! Topic is solved

Hi Giovanni, thanks for your answers. Sorry but i didn't realy understand what you said. I'm not realy confortable yet with debugging tool. In brief how can I track the problem? Do I have to use openOCD and the arm-none-gnueabi-gdb to see what going on? Or is it another way to find the problem? Than...
by tfAteba
Tue Nov 03, 2015 10:03 pm
Forum: General Support
Topic: ChibiOS RT Test Suit Problem! Topic is solved
Replies: 5
Views: 1309

ChibiOS RT Test Suit Problem! Topic is solved

Hello every body, Until now I was using ChibiOS version 2.6.x and I decide to pass to the last version 3.0.2 :D So the first thing I decide to to was to run the Test suit and I was surprise to see that the test doesn't complete. It stop at the step bellow: -------------------------------------------...
by tfAteba
Fri Oct 30, 2015 4:50 pm
Forum: STM32 Support
Topic: Question About NUCLEO411RE board Topic is solved
Replies: 2
Views: 865

Re: Question About NUCLEO411RE board Topic is solved

Hi,

I have to pass to ChibiOS 3 then, :). I was using the 2.6 and I think there is not the support for my board on this version of ChibiOS.

Thanks you for your reply.
by tfAteba
Fri Oct 30, 2015 12:33 am
Forum: STM32 Support
Topic: Question About NUCLEO411RE board Topic is solved
Replies: 2
Views: 865

Question About NUCLEO411RE board Topic is solved

Hello All, I have the NUCLEO411RE Board, and i want to use Chibios for my small project. But I want to know if the support for this board already exist or if I need to port? Because there is a directory for the NUCLEO401RE on the board folders and also on the demo. Can I used NUCLEO401 folders even ...

Go to advanced search