Search found 18 matches

by Adam
Wed Jul 23, 2014 8:56 am
Forum: STM32 Support
Topic: UART Driver for UART4 Peripheral
Replies: 4
Views: 1130

Re: UART Driver for UART4 Peripheral

Thank you so much for help! In new version (2.6.5) is UART4 already defined.

Adam
by Adam
Wed Jul 23, 2014 8:37 am
Forum: STM32 Support
Topic: UART Driver for UART4 Peripheral
Replies: 4
Views: 1130

Re: UART Driver for UART4 Peripheral

This is a part of my mcuconf.h: /* * UART driver system settings. */ #define STM32_UART_USE_USART1 FALSE #define STM32_UART_USE_USART2 FALSE #define STM32_UART_USE_USART3 FALSE #define STM32_UART_USE_USART6 FALSE #define STM32_UART_USART1_RX_DMA_STREAM STM32_DMA_STREAM_ID(2, 5) #define STM32_UART_US...
by Adam
Wed Jul 23, 2014 8:06 am
Forum: STM32 Support
Topic: UART Driver for UART4 Peripheral
Replies: 4
Views: 1130

UART Driver for UART4 Peripheral

Hi Giovanni!

(STM32F407)
Is possible use an UART Driver for an UART4 peripheral? I can run the UART4 with SerialDriver, but the SerialDriver is not good for RS485 mode.

Is there any way how to run UART4 peripheral with UART Driver?

Thank you!

Adam
by Adam
Mon Jan 20, 2014 2:43 pm
Forum: STM32 Support
Topic: [SOLVED] STM32F4 Backup SRAM loses data
Replies: 0
Views: 1571

[SOLVED] STM32F4 Backup SRAM loses data

Hi! I had this problem: My Backup SRAM lost data randomly when power connector was unplugged. I finally found the solution of this problem and I would like to share the problem solution here. For a long time I was looking for a problem in the configuration and init of the backup domain. Then I tried...
by Adam
Tue Jan 14, 2014 1:59 pm
Forum: General Support
Topic: Debug over serial
Replies: 5
Views: 1843

Re: Debug over serial

Ok, so when I enable option of debug checking of any subsystem to TRUE, system is automatically halted although it is only a warning?
by Adam
Tue Jan 14, 2014 1:28 pm
Forum: General Support
Topic: Debug over serial
Replies: 5
Views: 1843

Re: Debug over serial

I am using debugger from STM32F4-discovery board (wired to my board) + OpenOCD + Eclipse. How can I print debug messages on screen?
by Adam
Tue Jan 14, 2014 1:10 pm
Forum: General Support
Topic: Debug over serial
Replies: 5
Views: 1843

Debug over serial

Hi all! Is possible debug ChibiOS over serial? I mean - every assert, exception or warning write on serial link?If it is possible, can you tell me how to enable this feature? I found only Eclipse plugin, which I´am already using. And second question - Can I watch states of memories? How much the mem...
by Adam
Mon Dec 16, 2013 2:42 pm
Forum: User Projects
Topic: Adding DHCP, AutoIP and IGMP to LWIP support
Replies: 11
Views: 7185

Re: Adding DHCP, AutoIP and IGMP to LWIP support

I have already found my mistake... A setted up the MAC filter too early than I could. For others: Disable MAC filter after initialization of network stuffs. Disable MAC filter near before using netconn_recv.

Adam
by Adam
Fri Dec 13, 2013 11:19 am
Forum: User Projects
Topic: Adding DHCP, AutoIP and IGMP to LWIP support
Replies: 11
Views: 7185

Re: Adding DHCP, AutoIP and IGMP to LWIP support

Hi all! I can´t get to work multicast communication. DHCP is already working. AUTOIP is unwanted. Problem: err = netconn_join_leave_group(conn2, &mcast_addr, &thisif_ptr->ip_addr, NETCONN_JOIN); still waits for semaphore. Nothing is catched. My steps for IGMP config: added into lwipopts.h: /...
by Adam
Mon Dec 02, 2013 10:16 am
Forum: General Support
Topic: STM32F407 + LWIP + UDP: receiving is stopped after 9packets
Replies: 6
Views: 4356

Re: STM32F407 + LWIP + UDP: receiving is stopped after 9pack

It seems the problem is solved! The problem was in a bad use netbuf buffer. This is WRONG: static struct netbuf *recv_buf; recv_buf = netbuf_new(); netconn_recv(conn_ctrl_recv, &recv_buf); This is CORRECT: static struct netbuf *recv_buf; netconn_recv(conn_ctrl_recv, &recv_buf); Conclusion: D...

Go to advanced search