Search found 5 matches

by zie
Thu Dec 26, 2019 10:51 pm
Forum: ChibiStudio
Topic: VM_LinuxMint19.2_with_ChibiStudio, Password ?
Replies: 1
Views: 1170

VM_LinuxMint19.2_with_ChibiStudio, Password ?

Hi
I have installed the VM_LinuxMint19.2_with_ChibiStudio an i can start it.
But witch user name and witch password is used for this machine?
Sorry i do not found it in the wiki..
Regards Felix
by zie
Mon Aug 05, 2019 6:39 pm
Forum: STM32 Support
Topic: GPIO not working on STM32L462VE Topic is solved
Replies: 6
Views: 426

Re: GPIO not working on STM32L462VE Topic is solved

Hi Giovanni

Thanks for your help!
I have a measurement problem... Ground from Linux PC via USB ...

That's why it was working with Atollic Studio on Win7 Pc.
Many thanks for your help. I am excited about your OS.

Felix
by zie
Mon Aug 05, 2019 5:18 pm
Forum: STM32 Support
Topic: GPIO not working on STM32L462VE Topic is solved
Replies: 6
Views: 426

Re: GPIO not working on STM32L462VE Topic is solved

hi i think, they are outputs : GPIOB Pins 12..15 from board.h #define VAL_GPIOB_MODER ... (PIN_MODE_OUTPUT(GPIOB_FON_2m) | \ PIN_MODE_OUTPUT(GPIOB_FOFF_1m) | \ PIN_MODE_INPUT(GPIOB_IV_2m) | \ PIN_MODE_OUTPUT(GPIOB_FON_1m) | \ PIN_MODE_OUTPUT(GPIOB_outTXD_1m) | \ PIN_MODE_INPUT(GPIOB_inRXD_1m) | \ PI...
by zie
Mon Aug 05, 2019 11:27 am
Forum: STM32 Support
Topic: GPIO not working on STM32L462VE Topic is solved
Replies: 6
Views: 426

Re: GPIO not working on STM32L462VE Topic is solved

Hi Yes, i have adaptet also the boardfile: subtype = STM32L462xx and set all the GPIO (in/out etc.) the Hal_version is 5.0.x in the bordfile what other differences can i config in the board-file? The GPIO Registers are changing, but not the real outputs. The GPIO Registers are at correct address. GB...
by zie
Mon Aug 05, 2019 10:27 am
Forum: STM32 Support
Topic: GPIO not working on STM32L462VE Topic is solved
Replies: 6
Views: 426

GPIO not working on STM32L462VE Topic is solved

Hello I have adapted ChibiOS on my own board with STM32L462VE. (STM32_Registry to some other Files). As Linkerfile I copied STM32L432xB.ld to STM32L462VE.ld and change flash0: org = 0x08000000, len = 512k and ram0: org = 0x20000000, len = 160k STM32L462VE is used in the Makefile, I can compile and t...

Go to advanced search