Search found 96 matches

by wurstnase
Fri Nov 15, 2019 9:29 pm
Forum: ChibiOS/RT
Topic: encoding GPIO ports
Replies: 11
Views: 144

Re: encoding GPIO ports

Giovanni wrote:Just a detail, you can map multiple event sources to the same eventmask_t bit. Your handler can then poll the various listeners for available flags. RAM usage is true.


I can't follow you with this completely. Do you have a minimal example, please?
by wurstnase
Thu Nov 14, 2019 11:50 am
Forum: ChibiOS/RT
Topic: encoding GPIO ports
Replies: 11
Views: 144

Re: encoding GPIO ports

For something similar I'm using the PORT_LINE PAL_LINE macro. Probably this is what are you searching for.
by wurstnase
Sun Nov 10, 2019 3:50 pm
Forum: Bug Reports
Topic: Possible bug in ADC lld
Replies: 4
Views: 640

Re: Possible bug in ADC lld

I've seen that sometimes my ADC will not start. Could this be an issue with that part of code?

Unfortunately it is sometimes at some tools. Not anytime at any tool.
by wurstnase
Sun Nov 10, 2019 1:02 pm
Forum: Bug Reports
Topic: STM32 UART USARTv1 idle interrupt
Replies: 6
Views: 789

Re: STM32 UART USARTv1 idle interrupt

Please check also this thread:

viewtopic.php?f=38&t=5166&p=35901#p35901
by wurstnase
Fri Nov 08, 2019 11:04 am
Forum: Bug Reports
Topic: uartSendFullTimeout wrong transmitted bytes Topic is solved
Replies: 1
Views: 67

uartSendFullTimeout wrong transmitted bytes Topic is solved

While uartSendTimeout is correct: /* Waiting for result.*/ msg = osalThreadSuspendTimeoutS(&uartp->threadtx, timeout); if (msg != MSG_OK) { *np -= uartStopSendI(uartp); } uartSendFullTimeout is wrong: /* Waiting for result.*/ msg = osalThreadSuspendTimeoutS(&uartp->threadtx, timeout); if (ms...
by wurstnase
Sat Sep 28, 2019 2:30 pm
Forum: Bug Reports
Topic: i2cv1 up to 4 MHz? Topic is solved
Replies: 1
Views: 154

i2cv1 up to 4 MHz? Topic is solved

Hi, I don't know if it is a real bug. But I find only the "fast mode" for the STM32F1xx. And fast mode is <= 400kHz?!? But the the driver check is <= 4000kHz. Maybe a zero too much? os/hal/ports/STM32/LLD/I2Cv1/hal_i2c_lld.c static void i2c_lld_set_clock(I2CDriver *i2cp) { I2C_TypeDef *dp ...
by wurstnase
Fri Sep 06, 2019 11:28 am
Forum: ChibiStudio
Topic: Debug plugin with DSF support
Replies: 30
Views: 3629

Re: Debug plugin with DSF support

Yes, this was the correct hint.

Code: Select all

apt install ttf-mscorefonts-installer
by wurstnase
Fri Sep 06, 2019 10:56 am
Forum: ChibiStudio
Topic: Debug plugin with DSF support
Replies: 30
Views: 3629

Re: Debug plugin with DSF support

Hmmm...

The complete window is somehow :(

chibios_plugin_2.png


The rest in eclipse is working as expected.
by wurstnase
Fri Sep 06, 2019 8:14 am
Forum: ChibiStudio
Topic: Debug plugin with DSF support
Replies: 30
Views: 3629

Re: Debug plugin with DSF support

Do I need any special font for this plugin?

I just setup my complete computer and have now a pretty clean installation with Ubuntu Mate and Eclipse.
Last time I can read anything, but now I get squares:

chibios_plugin.png
by wurstnase
Fri Jul 26, 2019 9:04 am
Forum: Small Change Requests
Topic: Thread name for the shell Topic is solved
Replies: 1
Views: 175

Thread name for the shell Topic is solved

Hi,

attached a small patch to name the shell thread.

Go to advanced search