Search found 76 matches

by josesimoes
Sat Apr 27, 2019 7:44 am
Forum: Development and Feedback
Topic: [INFO] Moving repository to OSDN
Replies: 22
Views: 1455

Re: [INFO] Moving repository to OSDN

Just in case you need, here's another mirror on GitHub (it's updated twice a day):
https://github.com/nanoframework/ChibiOS
by josesimoes
Fri Apr 26, 2019 7:19 pm
Forum: STM32 Support
Topic: WSPI on STM32F769I Topic is solved
Replies: 4
Views: 229

Re: WSPI on STM32F769I Topic is solved

Got it! I went through all the possible configs and bumped into the clock setting. I've added the following to mcuconf.h and it's now readin the expected IDs: #define STM32_WSPI_QUADSPI1_PRESCALER_VALUE 2 Suggestion maybe this config should be made more "visible"... Thanks anyway for looki...
by josesimoes
Fri Apr 26, 2019 7:16 pm
Forum: STM32 Support
Topic: WSPI on STM32F769I Topic is solved
Replies: 4
Views: 229

Re: WSPI on STM32F769I Topic is solved

I believe yes... the hardware is the STM board, so I trust it's working OK.
I've setup board.h to properly set the pin configs, including the AF values.

Also double check the commands against the ChibiOS driver.
by josesimoes
Fri Apr 26, 2019 7:06 pm
Forum: STM32 Support
Topic: WSPI on STM32F769I Topic is solved
Replies: 4
Views: 229

WSPI on STM32F769I Topic is solved

Hi, I was coding a driver to use SPIFFs on the SMT32F769I-DISCO board (has a MX25L51245G). The WSPI driver, clock and DMA seem to be properly configured as I can successfully issue the RST enable (RSTEN) and RST commands. When reading the device ID (RDID) I get unexpected values: 0x30 0x88 0x06 I've...
by josesimoes
Mon Apr 08, 2019 4:43 pm
Forum: Bug Reports
Topic: TX failing on UART7 (STM32F469) Topic is solved
Replies: 2
Views: 247

TX failing on UART7 (STM32F469) Topic is solved

Hi, I was testing the recently added support for UART7 in STM32F4 and I can't seem to TX anything on UART7. I've double checked the pin assingments in board.h they are correct, including setting of AF to 8. I've double checked the buffers and they are OK. DMA channel assingment too. Ultimate test wa...
by josesimoes
Sun Mar 10, 2019 9:24 pm
Forum: Bug Reports
Topic: SD card write in STM32F7
Replies: 6
Views: 551

Re: SD card write in STM32F7

That has crossed my mind... I thought that should probably the callers responsibility. But, then again, maybe it should be in the wrappers too...
by josesimoes
Sun Mar 10, 2019 12:31 pm
Forum: Bug Reports
Topic: SD card write in STM32F7
Replies: 6
Views: 551

Re: SD card write in STM32F7

Actually this requires a bit more than the above fix. For SPI access the writes are done in batches so invalidating all the buffer at start won't work. This should be the correct fix: { switch (pdrv) { #if HAL_USE_MMC_SPI case MMC: if (blkGetDriverState(&FATFS_HAL_DEVICE) != BLK_READY) return RE...
by josesimoes
Thu Mar 07, 2019 5:15 pm
Forum: Bug Reports
Topic: SD card write in STM32F7
Replies: 6
Views: 551

Re: SD card write in STM32F7

Hi Giovanni, Following your suggestion I've added: // invalidate cache on buffer cacheBufferFlush(buff, count * MMCSD_BLOCK_SIZE); at line 166 of fatfs_diskio.c and the writes on the SD card are now working perfectily on the STM32F769I. I now understand that my previous attempts to invalidate the ca...
by josesimoes
Mon Mar 04, 2019 7:33 pm
Forum: Bug Reports
Topic: SD card write in STM32F7
Replies: 6
Views: 551

SD card write in STM32F7

Hi, I'm trying to write to SD Card on STM32F769I-DISCO1 board. Had to adjust the the configurations because the SD Card connector on this board is wired to SDMMC 2-. This requires hacking "halconf.h" to force FATFS_HAL_DEVICE. #if !defined(FATFS_HAL_DEVICE) || defined(__DOXYGEN__) //this b...
by josesimoes
Thu Jan 10, 2019 11:36 am
Forum: STM32 Support
Topic: New STM32 series STM32G0
Replies: 4
Views: 557

Re: New STM32 series STM32G0

Absolutely!! Efficiency and elegance are attributes that go along with ChibiOS!! :D

Go to advanced search