Search found 24 matches

by crispus
Sat Dec 07, 2019 3:19 pm
Forum: General Support
Topic: I2C "SearchDevices on bus"
Replies: 4
Views: 1603

Re: I2C "SearchDevices on bus"

I know this thread is old, but I kinda got around it by restarting the i2c driver:

Code: Select all

       i2cStop(cpuI2C);
       i2cStart(cpuI2C, &cpuI2cCfg);
       msg_t ret = i2cMasterTransmitTimeout(cpuI2C, addr, tx_buffer, 1,
                rx_buffer, 0, TIME_MS2I(10));
by crispus
Sun Jan 13, 2019 5:31 pm
Forum: Bug Reports
Topic: Nucleo F767ZI - linker script and breakpoints Topic is solved
Replies: 9
Views: 1385

Nucleo F767ZI - linker script and breakpoints Topic is solved

Hi, I was complaining some time ago about H7 linker script I have similar issue with F767ZIH. After loading the binary with the gdb: (gdb) load Loading section .vectors, size 0x200 lma 0x8000000 Loading section .xtors, size 0x8 lma 0x8000200 Loading section .text, size 0x89e8 lma 0x8000210 Loading s...
by crispus
Thu Sep 20, 2018 5:34 pm
Forum: Bug Reports
Topic: build Chibios Under Atollic Topic is solved
Replies: 14
Views: 2886

Re: build Chibios Under Atollic Topic is solved

TWIMC: As a workaround, replacing flash1 with flash0 on each alias compiles and works ok (on ST-Nucleo-H743ZI) $ svn diff Index: os/common/startup/ARMCMx/compilers/GCC/ld/STM32H743xI.ld =================================================================== --- os/common/startup/ARMCMx/compilers/GCC/ld/...
by crispus
Thu Sep 06, 2018 1:04 pm
Forum: Bug Reports
Topic: build Chibios Under Atollic Topic is solved
Replies: 14
Views: 2886

Re: build Chibios Under Atollic Topic is solved

Using F7 linker scripts it will compile (at least). So, I was comparing the linker scripts for H7 and F7 and I see that flash0 anf flash1 although point to the same thing (?) they have different addresses, but not for H7 (bank1+bank2 vs bank1). H7 flash0 : org = 0x08000000, len = 2M /* Flash bank1+b...
by crispus
Wed Sep 05, 2018 8:04 pm
Forum: Bug Reports
Topic: build Chibios Under Atollic Topic is solved
Replies: 14
Views: 2886

Re: build Chibios Under Atollic Topic is solved

It seems that is coming from C++ stuff (commenting cpp out it will compile). I have nothing fancy/complex, just 2 classes.
On same configuration STM32F767 compiles just fine.

Code: Select all

include $(CHIBIOS)/os/various/cpp_wrappers/chcpp.mk
by crispus
Wed Sep 05, 2018 6:45 pm
Forum: Bug Reports
Topic: build Chibios Under Atollic Topic is solved
Replies: 14
Views: 2886

Re: build Chibios Under Atollic Topic is solved

Latest version from dev.arm.com: GNU Arm Embedded Toolchain Version 7-2018-q2-update (7.3.1) and 6.3.1 from debian repo.

Since STM32H7 is M7 I didn't expected to have an compiler/linker problem...
by crispus
Wed Sep 05, 2018 4:57 pm
Forum: Bug Reports
Topic: build Chibios Under Atollic Topic is solved
Replies: 14
Views: 2886

Re: build Chibios Topic is solved

I have a similar issue while trying to compile for STM32H743ZIT6 /usr/lib/gcc/arm-none-eabi/6.3.1/../../../arm-none-eabi/bin/ld: section .rodata VMA [0000000008008e90,0000000008009e77] overlaps section .text VMA [00000000080002c0,0000000008008eab] I am using command line (Debian testing) with the Ma...
by crispus
Tue Sep 12, 2017 7:40 pm
Forum: Bug Reports
Topic: STM32F4xx EXTIv1 compilation error Topic is solved
Replies: 2
Views: 987

Re: STM32F4xx EXTIv1 compilation error Topic is solved

Hi Giovanni,

Thanks for the reply. I missed that out.
by crispus
Tue Sep 12, 2017 4:17 pm
Forum: Bug Reports
Topic: STM32F4xx EXTIv1 compilation error Topic is solved
Replies: 2
Views: 987

STM32F4xx EXTIv1 compilation error Topic is solved

$(CHIBIOS)/os/hal/ports/STM32/STM32F3xxHi, My environment: - ChibiOS version: https://github.com/ChibiOS/ChibiOS master branch, namely svn://svn.code.sf.net/p/chibios/svn/trunk@10573 - Compiler: gcc version 6.3.1 20170620 - Platform and board: STM32F4xx, STM32F207 nucleo 144 board - Nature of the pr...
by crispus
Mon Jun 12, 2017 9:44 am
Forum: ChibiOS/HAL
Topic: I2C slave-RX plus master transmit = LOCKED
Replies: 4
Views: 2018

Re: I2C slave-RX plus master transmit = LOCKED

I have same problem with F2 board (Nucleo-F207ZG) (ChibiOS - the current github master branch) and a BM085 sensor. Sometimes I receive a timeout. Is this the recommended approach to recover from the locked state? err = i2cMasterTransmitTimeout(&elfI2C, replyDstAdr, txBody, replyLen, crcBuf, 1, r...

Go to advanced search