Search found 90 matches

by ep.hobbyiest
Thu Jan 11, 2018 6:08 pm
Forum: STM32 Support
Topic: Need help with i2c restart sequence
Replies: 5
Views: 350

Re: Need help with i2c restart sequence

Thanks tfAteba.
But i am looking for i2c restart condiiton which requires while sending data which to be display.

if i use i2cMasterTransmitTimeout function then it will generate i2c start and i2c stop condition.

could you please share your code for ssd1306 lcd. it will be very helpful.
by ep.hobbyiest
Wed Jan 10, 2018 3:27 pm
Forum: STM32 Support
Topic: Need help with i2c restart sequence
Replies: 5
Views: 350

Need help with i2c restart sequence

Hi, I am using latest chibios version and STM32F103xx controller. I want to interface oled ssd1306 display with i2c interface. I got stage where we have to send some commands and the later without stop condition we have to send start condition(Restart condition) and then we have to send data to disp...
by ep.hobbyiest
Sat Dec 16, 2017 4:59 am
Forum: STM32 Support
Topic: No rule to make target `chcoreasm_v7m.S
Replies: 4
Views: 299

Re: No rule to make target `chcoreasm_v7m.S

Thanks for figuring out. Currently i am using chibi studio which has folder name as chibios3 , i am not able to find out the os version from that. i checked following versions but everyone has folder name as chibios30. ChibiStudio_Preview16.7 ChibiStudio_Preview17.7 ChibiStudio_Preview18.7 ChibiStud...
by ep.hobbyiest
Fri Dec 15, 2017 5:26 pm
Forum: STM32 Support
Topic: No rule to make target `chcoreasm_v7m.S
Replies: 4
Views: 299

Re: No rule to make target `chcoreasm_v7m.S

i checked and copied files there but then also i got same error. i copied files chcoreasm_v7m.s and chcoreasm_v6m.s to C:\ChibiStudio\chibios30\os\rt\ports\ARMCMx\compilers\GCC path.. Now also if i create new project with copy base of old existing project that time also i get error as follows.. 22:3...
by ep.hobbyiest
Fri Dec 15, 2017 3:34 pm
Forum: STM32 Support
Topic: No rule to make target `chcoreasm_v7m.S
Replies: 4
Views: 299

No rule to make target `chcoreasm_v7m.S

I got following error while compiling existing project. Controller: STM32F4 Chibios veriosn : ChibiStudio_Preview17.7 error is: make all Compiler Options arm-none-eabi-gcc -c -mcpu=cortex-m4 -Os -ggdb -fomit-frame-pointer -falign-functions=16 -ffunction-sections -fdata-sections -fno-common -flto -Wa...
by ep.hobbyiest
Tue Dec 12, 2017 3:41 am
Forum: STM32 Support
Topic: error:not defined IAD in usb host
Replies: 0
Views: 170

error:not defined IAD in usb host

Hi, i am using stm32f4 discovery board.I was using USBH driver for usb host application.I got the code from Contrib repo(developed by @dismirlian). I want to use usb stick to connect with stm32f4 board and collect some data. I don't need to use/enumarate other class devices. Behavior: i compiled the...
by ep.hobbyiest
Fri Dec 08, 2017 4:58 pm
Forum: General Support
Topic: fatal error: LTO_tags out of range
Replies: 2
Views: 184

Re: fatal error: LTO_tags out of range

yeah. Error was something related to workspace.
I took new chibi studio again and made new project. then after that started working..

Something got corrupted i guess.
by ep.hobbyiest
Thu Dec 07, 2017 6:09 pm
Forum: General Support
Topic: fatal error: LTO_tags out of range
Replies: 2
Views: 184

fatal error: LTO_tags out of range

Hi, I was using chibistudio yesterday and it was working fine. But today after compiling code i got following error. I tried new version as well and new chibistudio then also it is exist. Here is error i have attached. lto1.exe: fatal error: LTO_tags out of range: Range is 0 to 361, value is 20480 c...
by ep.hobbyiest
Tue Nov 28, 2017 7:21 pm
Forum: General Support
Topic: Need Help with SPI1
Replies: 3
Views: 204

Re: Need Help with SPI1

Yes. SPI1 is functional. I could read and write data to NRF24L01 module.
And also i took reference from SPI example.

I have narrowwed down the problem. I am facing problem while Receiving only. I think i use spisend and spireceive one after another then this problem comes.
by ep.hobbyiest
Tue Nov 28, 2017 5:24 pm
Forum: General Support
Topic: Need Help with SPI1
Replies: 3
Views: 204

Need Help with SPI1

Hi, I am using STM32F103c8t6 and NRF24L01 rf module. I am using PA4, PA5, PA6, PA7 pins for SPI.(PA4 - Chip Select). I am refering code but in that code Software SPI was implemented. While using code in RX mode it is getting stuck some where. Not able to communicate properly. Here is PIN Configurati...

Go to advanced search