Search found 26 matches

by mikenick42
Tue Jun 02, 2020 2:19 pm
Forum: Small Change Requests
Topic: LWIP improvements Topic is solved
Replies: 27
Views: 5955

Re: LWIP improvements Topic is solved

Giovanni, I can put together a patch with my changes for the iGMP flag. It's only a couple lines, but my concern is that for my quick-and-dirty solution, I added #include stlib.h to lwipopts.h because with the IGMP true I needed to define LWIP_RAND as (uint32)rand() which may or may not be the right...
by mikenick42
Fri May 29, 2020 4:56 pm
Forum: Small Change Requests
Topic: LWIP improvements Topic is solved
Replies: 27
Views: 5955

Re: LWIP improvements Topic is solved

Hi all, I'm curious about what happened with #7 from geebee's driver. I'm trying to get a PTP driver working with multicast and when I add the NETIF_FLAG_IGMP flag to lwip_thread.c, everything seems to work. It looks like you may be working on a more flexible solution to the problem though, and I wo...
by mikenick42
Sun May 06, 2018 1:59 am
Forum: AVR Support
Topic: 18.2 on an Arduino Uno Topic is solved
Replies: 8
Views: 5393

Re: 18.2 on an Arduino Uno Topic is solved

Yeah, I saw the verification fail when I was about halfway through that last post. It looks like the '-D' flag was added to the default avrdude command generated by the Makefile. So the flash was never being erased when I reprogrammed it. If I take that out everything works fine. Thanks for the help.
by mikenick42
Sat May 05, 2018 12:00 am
Forum: AVR Support
Topic: 18.2 on an Arduino Uno Topic is solved
Replies: 8
Views: 5393

Re: 18.2 on an Arduino Uno Topic is solved

I have no reason to believe there's anything wrong with my hardware. I'm using a generic UNO clone and a usbASP clone. They've both worked fine in the past. I have the same results with both the RT and NIL projects. When I run 'make program' on the stable_16.1.x branch everything works fine, but whe...
by mikenick42
Mon Apr 30, 2018 11:27 pm
Forum: AVR Support
Topic: 18.2 on an Arduino Uno Topic is solved
Replies: 8
Views: 5393

Re: 18.2 on an Arduino Uno Topic is solved

Thanks. I can help if there's anything you need me to test.
by mikenick42
Mon Apr 30, 2018 3:20 am
Forum: AVR Support
Topic: 18.2 on an Arduino Uno Topic is solved
Replies: 8
Views: 5393

18.2 on an Arduino Uno Topic is solved

Hi, It's been a while since I've been able to work on any of this and am having some issues getting the 18.2.x stable branch to run on an Uno. If I revert to stable_16.2.x I can run the demos and everything seems fine, but when I checkout stable_18.2.x, the board seems to program but the led doesn't...
by mikenick42
Thu May 04, 2017 3:28 am
Forum: AVR Support
Topic: Fast system tick on AVR
Replies: 8
Views: 2396

Re: Fast system tick on AVR

Hi Giovanni, There are a couple of 8bit counters and one 16bit counter. It looks like in tickless mode the 16bit counter is used, and in periodic mode an 8bit counter is used. st_lld.c has the divider for tickless mode hard-coded to 1024. I played with that quite a while ago and I think had some suc...
by mikenick42
Wed May 03, 2017 2:39 am
Forum: AVR Support
Topic: Fast system tick on AVR
Replies: 8
Views: 2396

Re: Fast system tick on AVR

Hi Giovanni, I've used the hal PWM drivers before and they're definitely nice. But for this project I'm driving an SSR that has an AC load. So once I enable the output line, the load won't turn back off until there's a zero-crossing, so I don't think traditional PWM would work. I think I want basica...
by mikenick42
Tue May 02, 2017 2:51 am
Forum: AVR Support
Topic: Fast system tick on AVR
Replies: 8
Views: 2396

Re: Fast system tick on AVR

Hi Theo, After some more reading today, I suspect that I'm coming at this the wrong way. I'm trying to use PWM to control a mains power source, similar to what's shown in Figure 4 here: https://electronics.stackexchange.com/a/233804 Using the default settings in ChibiOS I get ~67 system ticks betwee...
by mikenick42
Sun Apr 30, 2017 1:39 pm
Forum: AVR Support
Topic: Fast system tick on AVR
Replies: 8
Views: 2396

Re: Fast system tick on AVR

Hi Theo,

I'm using the stable 16.1 branch on an Uno.

Thanks,
Mike

Go to advanced search