Search found 126 matches

by avrhack
Sun May 19, 2019 4:47 pm
Forum: Development and Feedback
Topic: Race condition with palWaitPadTimeout
Replies: 1
Views: 151

Race condition with palWaitPadTimeout

I'm processing "interrupts" from an external SPI Ethernet MAC/PHY using the PAL events subsystem on the main thread, but after a while things stop. I'm 99% sure the issue is with a race condition which I can't see how to correct, but can't believe Giovanni hasn't got covered as otherwise t...
by avrhack
Thu Mar 28, 2019 3:10 pm
Forum: Development and Feedback
Topic: USB on STM32L432 Driving Me NUTS!
Replies: 10
Views: 496

Re: USB on STM32L432 Driving Me NUTS!

Hi, I can't debug it that way unfortunately - Blackmagic Probe no longer seems to work with the L4 series, tried loads of different versions and none of them work for me any more. Still great for the F0 and F3 but L4 is totally broken in terms of BMP. Hum, i have no problem using BMP with L4, I eve...
by avrhack
Thu Mar 28, 2019 3:07 pm
Forum: Development and Feedback
Topic: USB on STM32L432 Driving Me NUTS!
Replies: 10
Views: 496

Re: USB on STM32L432 Driving Me NUTS!

There is nothing that can suspend all other threads except a thread looping indefinitely at higher priority. Giovanni Well the issue was a suspended thread causing all others to stop - even though they were all the same priority and I had set up pre-emptive scheduling round robin specifically to av...
by avrhack
Thu Mar 28, 2019 9:58 am
Forum: Development and Feedback
Topic: USB on STM32L432 Driving Me NUTS!
Replies: 10
Views: 496

Re: USB on STM32L432 Driving Me NUTS!

If I disable the thread that reads from USB and I immediately return from the thread that writes to USB everything works. So there's something in either of those routines that blocks everything - all threads just stop. I'm going to narrow it down now to whether it's read or write then I'll share the...
by avrhack
Thu Mar 28, 2019 9:46 am
Forum: Development and Feedback
Topic: USB on STM32L432 Driving Me NUTS!
Replies: 10
Views: 496

Re: USB on STM32L432 Driving Me NUTS!

I can't debug it that way unfortunately - Blackmagic Probe no longer seems to work with the L4 series, tried loads of different versions and none of them work for me any more. Still great for the F0 and F3 but L4 is totally broken in terms of BMP. And it can't be a halt with a ChibiOS debug assert a...
by avrhack
Thu Mar 28, 2019 9:30 am
Forum: Development and Feedback
Topic: USB on STM32L432 Driving Me NUTS!
Replies: 10
Views: 496

USB on STM32L432 Driving Me NUTS!

OK I'm sure I'm doing something stupid, but this is driving me nuts. I have a perfectly working app on an STM32L432 when USB is connected and working. There's also an LED which flashes briefly every 5 seconds to show activity - it runs in the main loop. There are two other threads which cover readin...
by avrhack
Wed Nov 14, 2018 2:34 pm
Forum: ESP32 Support
Topic: ESP32
Replies: 32
Views: 4683

Re: ESP32

Giovanni wrote:I just created the forum (icon missing), moving this topic there.

Anybody volunteering as moderator? not much to do anyway, usually I cut problems "at the root".

Giovanni


I’m not working at the moment so I have the time potentially. What’s involved in moderation?
by avrhack
Tue Nov 13, 2018 4:15 pm
Forum: ESP32 Support
Topic: ESP32
Replies: 32
Views: 4683

Re: ESP32

I'd be interested in ChibiOS on the esp8266 as well as the esp32 - maybe we could do both at the same time? Or do the differences make that impractical ie we really need to treat them as two totally separate ports?
by avrhack
Tue Oct 09, 2018 12:58 pm
Forum: STM32 Support
Topic: STM32L462 Looks Interesting Topic is solved
Replies: 14
Views: 2603

Re: STM32L462 Looks Interesting Topic is solved

Giovanni wrote:Hi,

You need to add an entry in the registry file and add checks to hal_lld.h. It is very similar to 432 so it should work without other changes.

Giovanni


Will do. Presumably I’ll then send you what I’ve done for incorporation into future updates to the HAL?
by avrhack
Tue Oct 09, 2018 10:56 am
Forum: STM32 Support
Topic: STM32L462 Looks Interesting Topic is solved
Replies: 14
Views: 2603

Re: STM32L462 Looks Interesting Topic is solved

I note that whilst the L432 has appeared in the stm32_registry, there's still no support for the L462.

What do I need to do to get this support into ChibiOS?

Go to advanced search